Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I try to invoke Google Now by swiping up from the Home button, I get the message "Network error. Check your network connections and try again". I have a solid WiFi signal, and searches from the search bar work fine. I get the same message when I go into settings after launching Google Search and try to enable Google Now.

ASUS Transformer Prime, Android 4.1.1

share|improve this question
I received the 4.1.1 update back in September, but hadn't tried Google Now until recently - thus it's never worked for me. – TomG Dec 13 '12 at 2:45
Tried clearing app data for Google Search? – Suraj Bajaj Dec 13 '12 at 13:33
@SurajBajaj - great idea, but it didn't help. – TomG Dec 13 '12 at 19:37
I am getting this same issue on my brand new Galaxy Nexus. – MarkB42 Dec 23 '12 at 21:44
I know you're saying you "received" the update, but just to clarify, are you on the official update channel, or are you using a custom rooted ROM? – Harsha K Jan 2 '13 at 23:37
up vote 7 down vote accepted

Finally found the answer. I had four Google accounts - one of them could not sync because it required domain policy to be enforced, and I hadn't allowed that. I connected the tablet to my laptop and used adb logcat to see what was being logged when the error was displayed:

I/GLSUser (28125): GLS error: DeviceManagementRequiredOrSyncDisabled <<account name redacted>> oauth2:
V/GoogleLoginService(28125): Returning error intent with: ComponentInfo{}
E/Velvet.VelvetNetworkClient( 4564): Failed to get auth token

(these messages were repeated several times).

I guessed that the errant account may have been involved (even though it was not the account I was trying to active Now with), removed the account from the device and all is well.

share|improve this answer

Google Now is not available in countries and languages as yet, so you may be in a country were it is not supported. You can still search on Google's homepage, or I suppose you could try a proxy or flashing your phone in such a way to make it believe it is somewhere else in the world were Google Now works

share|improve this answer
Unfortunately, I'm in the US, and English (US) is my default language. – TomG Jan 4 '13 at 0:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.