Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I am trying to communicate with an ethernet enabled devices from my Android phone. My phone has Android 2.3.6 and the device I am trying to communicate with has a mini web server running on it. The device has a single RJ45 port for communication with the outside word. Is it possible for me to connect my Android phone using a micro usb to Ethernet adapter and talk to the mini web server? If so, could you kindly show me how to go about this.

I have connected my Nexus One and tried to enable USB tethering but it doesn't work. I was reading an article on ADB but it doesn't show how to establish connection and assign address to an adapter.

share|improve this question
    
I am hoping not to need any programming. However, if it does require me to write some code, then I will definitely ask on Stack Overflow. Thanks for the heads up –  gzayzay Dec 13 '12 at 22:17
1  
Does your Nexus One recognize the ethernet adapter? Do you have a wired router? Could you plug the mini web server and phone into a router? (This would allow DHCP to assign IPs and then you would have a way to communicate.) –  ZnewmaN Dec 13 '12 at 22:20
    
The Nexus One does not seem to be recognizing the ethernet adapter. Is there any other Andriod Phone that allows this? For my class design project, we need to only communicate via wire directly with the phone. One of the constrains is that, no wifi or cellular connection can be used. So, in short, we can only use the micro usb to ethernet adapter and connect directly to the device. If there is any other android base device that I can use, please let me know. For now, I already had a Nexus One so we decided to use it –  gzayzay Dec 13 '12 at 22:37
1  
Is your device rooted? With a terminal emulator you could set a static ip for the ethernet adapter that is in the same subnet as the server. –  ZnewmaN Dec 13 '12 at 22:42
    
Yes the phone is rooted. I tried ifconfig usb0 192.168.x.x but it didn't work. I was able to log into the shell using adb when I connected the micro usb to USB cable directly to my laptop. Is there another way you recommend? –  gzayzay Dec 14 '12 at 13:46
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.