Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Ever since I upgraded my Google+ app on Friday (3.3.0.40049528) one of my favorite features, Image Instant Upload, is not working.

One of the big changes in this release was that instant upload could now upload full size images, rather than limiting them to 2048px.

  • I have plenty of available storage (4GB out of 5GB available)
  • I have force stopped the Google+ app as well as cleared the data at least once
  • The phone (Verizon Galaxy Nexus) has been restarted a couple of times
  • I am using the stock camera app for my testing
  • The settings were not changed when I updated Google+, but I have confirmed that Instant Upload is set to allow photo uploads on wifi as well as mobile data. I do not have "upload only when charging" turned on, and there is plenty of battery available.

Any ideas? Have I got a bug that needs an update?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

In Settings->Accounts and Sync->Your Google Account make sure Google Photos is selected

This is in Settings->Google in 4.x.

EDIT: I just checked, and reinstalling the Google+ all fixed this. Uninstall the app, then install it again.

You then need to go into the settings menu and enable instant upload.

share|improve this answer
    
Google Photos was already checked for syncing. –  Al E. Dec 16 '12 at 14:47
    
You should also have an Instant Upload option for syncing. If you do not, like I did not, you should reinstall the app and it will show. –  Liam W Dec 16 '12 at 15:09
    
I do, and it's checked. –  Al E. Dec 16 '12 at 16:50
1  
Things seem to be working now, although I'm not sure exactly why. I didn't uninstall the app updates, but I believe that that would have solved my problem. I don't know exactly what did, but your answer makes the most sense to me, which is why I've accepted it. –  Al E. Dec 16 '12 at 16:53
add comment

What I ended up doing was selecting the "Upload all" option under the Google+ settings for Instant Upload. This uploaded some photos that hadn't already been uploaded and seems to have kick-started the process.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.