Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So I'm on a Galaxy Nexus. Still on 4.1. I tried the 'hack' where you clear data on the Google Services Framework, then check update, but no luck. I shrugged and got on with my day.

Now I'm noticing that I have several updates in the play store. And if I choose "update" all I get is an instant "Update for [app name] could not be downloaded". Repeatedly.

I've tried clearing data for the play store, rebooting, but nothing.

Yay. Any theories?

share|improve this question
up vote 4 down vote accepted

Remove and add again your Google (main) user account. This should do the trick.

share|improve this answer
Thank you good sir. I knew I'd done it before and that there was some easy fix, that's the one. – Mark Mayo Dec 18 '12 at 6:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.