Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a new Indian Android variant i.e Wynncom g1 [ spreadtrum sp8810 ] I have gotten ADB to work with PDANet application and got USB drivers and adb to work. I tried many ways like adb root and all, then tried superoneclick, unlock root but they didn't worked and I also tried apks like gingerbreak, z4root but they also didn't worked.

My OS Information and Board information :

  • Model : Wynncom G1
  • Android Version : 2.3.5
  • GPU : Mali-300
  • Kernel is .35
  • CPU : ARMv7
  • CPU HARDWARE : Spreadtrum SP8810
share|improve this question
    
Tried mempodroid already? Also, see xray.io/dl for a checking app by security research company duosecurity. –  ce4 Dec 18 '12 at 14:25
    
I searched for mempodroid it says that exploit for .39+ kernel and that can be seen only on ics or later version mine phone is 2.3.5 so kernel is .35 :( anyother idea? –  Keyur Maru Dec 19 '12 at 9:40
    
If Xray finds one, take that. Else you're out of luck, you only could find a custom exploit yourself, maybe some symlink/access write bug in the initrc (e.g, if /data/local/tmp gets chmodded to 777, remove it and create a symlink to /dev/block/your.data.permission and then use debugfs to create build.local with ro.secure=0 ) –  ce4 Dec 19 '12 at 13:24
    
possible duplicate of How do I root my device? –  Lie Ryan Dec 19 '12 at 15:04
1  
@LieRyan We don't duplicate close device rooting questions any more. See meta.android.stackexchange.com/questions/790/… –  Flow Dec 19 '12 at 17:14
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.