Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I'm loving my Android phone (Incredible) but I cannot stand when the browser automatically inserts "www" at the beginning of any URL I'm trying to type. I am a web developer and work a lot with sub domains (not to mention blind usage of "www" is bad practice) and it gets frustrating.

Any ideas?

share|improve this question
2  
Then how would you know that you are on the world wide web? –  Matt Dec 13 '10 at 18:36
2  
I have never seen this behavior. It must be Incredible-specific. –  Matthew Read Dec 13 '10 at 19:44
    
Is it entering it as you type or after you hit Go? It is also helpful to mention what browser you are using when you see this behavior. The Dolphin Browser HD doesn't do this to me however certain sites automatically redirect to the www. when no subdomain is submitted. This is controlled at the site level by any url rewrite rules they have. –  Matt Dec 13 '10 at 20:56
    
@Matt: He does say that he's using the Android browser. I've not seen this behavior either. –  Al E. Dec 14 '10 at 13:13
    
@Joel, I don't have this problem here either (Android 2.2 on HTC EVO). Is it simply remembering a previous URL? –  Brad Dec 14 '10 at 14:52
show 2 more comments

4 Answers

It seems to be specific to the HTC Droid Incredible. When I first tried to search from the stock browser, I'd get an error page (I didn't notice the "http://www"). So I asked this question which gave some options in the form of browsers which are ready for search queries. (It turns out you can search from the stock browser once you delete the "http://www")

You may want to use another browser. In the Dolphin HD browser for example, the "www" isn't there so typing "android.stackexchange.com" works fine.

share|improve this answer
add comment

Two things to try:

  1. Delete everything from the url textbox and enter the url, for example "android.stackexchange.com"
  2. Remove the www. part and enter the rest of the url behind http://.

Both of these methods work on my Droid Incredible running stock 2.2 (rooted)

share|improve this answer
add comment

I don't have my phone here to try ... but can it be a specific keyboard which is selected ( and where words are automatically inserted ). F.i. using SWYPE and having word prediction on ?

share|improve this answer
add comment

On the HTC Desire HD (2.2, standard browser), the behaviour when you tap in the address bar appears to be:

  • If the URL currently in the address bar already starts with www. then everything after the www. is auto-selected, meaning that whatever you type will replace it, leaving the www. in place.
  • If the URL currently in the address bar doesn't start with www. then the full URL (everything following http://) is selected, meaning that what you type will form the full URL.

I can't find a way of disabling this, and quite regularly end up trying to go to www.www.google.com.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.