Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've a Vonino Luna 70C tab with Android Ice Cream 4.0.4. Today, while watching an YouTube video, my WiFi connection went down all of the sudden. After restarting the tablet, I couldn't turn WiFi on anymore: the status button was going from "On" to "Off" all by itself and the message was stuck at "Turning WiFi on...". I've tried several methods to get this fixed, yet none of them worked. Any help is much appreciated! I have to mention that I bought my tablet yesterday, so I doubt there's anything wrong with the hardware.

PS: While logging the connection process with LogCat, I ran into this error: "failed to read proc/net/wireless/". It spams it a little bit, after which it returns a fatal error: time out. I've tried creating the directory myself, hoping that it would fix the problem, but I cannot create it. (I have to mention that I am not on a rooted device.) Can it be something related to permission issues?

Thanks in advance,

EDIT: I thought a log would come in-handy. Pastebin ->

share|improve this question
Tried having the device in airplane mode and then back to normal? – Power-Inside Dec 26 '12 at 6:35
Yes, I have. Nothing changed. I tried chmoding the /proc/net/wireless file via ADB, but for some reasons it wont save the chmod. (Yes, I am root.) – Alexandru Dec 26 '12 at 8:58

protected by Community Oct 23 '14 at 21:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.