Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have ICS on my Samsung S2 I9100 phone. I was able to turn on WiFi until about today afternoon. Now, from recently though, whenever I turn on WiFi, it does not turn on WiFi at all: the device shows that it is re-trying to turn WiFi on, but the status remains "off". Hence, I am unable to see a list asvailable WiFi networks.

I have not installed any new app or updated any existing apps for this issue to suddenly occur. Any idea why this is happening, and how I can solve this issue?

share|improve this question
    
Have you tried the Windows-repair-Method (reboot, switching it off and on again, maybe even take out the battery for 15..30s between power-off and power-on)? –  Izzy Dec 29 '12 at 19:02
    
Yup.. Even tried taking the battery out the whole night and starting it up again in the morning.. Removed the external SD card and then started it up again.. Some people say the wifi adapter might be damaged.. But then, i am able to see a perfectly valid MAC address of the wifi card in the settings.. Which i guess wouldnt be possible if the wifi card bonked out.. –  Venkatesh Dec 30 '12 at 6:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.