Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

When I turn on vibration in the notification bar, my phone doesn't vibrate when I get SMS but it vibrates when someone calls me.

I saw that there is a setting in Messaging > Settings > Vibrate where I can check only that option. On some other phones I saw on the internet, there is a new menu that offers you to check always, only in silent mode, and never.

Edit #1: What I want: When I set sound mode in notification bar, it should only give me sound. When I set it to vibrate mode, it should only vibrate. The problem is only with SMS, not with calls. When it is set to vibrate mode, if I uncheck vibrate notification in message settings it will not vibrate, it only turns on display.

share|improve this question

closed as unclear what you're asking by geffchang, Izzy, ce4, Al E., Zuul Jul 3 '13 at 12:27

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

    
NOTE: I'm having trouble rephrasing your question. But seeing that you have not come back to clarify it, I think this question should be closed. And it's a rather OLD question. –  geffchang Jul 3 '13 at 5:04

1 Answer 1

This sounds like the old Gingerbread (Android 2.3.x) had the option to set vibrate to one of three options, from within SMS Messaging App in Settings:

  • Always
  • Only when Silent
  • Never

In the newer version of Android 4.x. Ice Cream Sandwich and upwards, that was changed slightly, now the settings reflect as:

  • Enable, by tapping on Notifications (First, that's a pre-requisite as it will activate the options underneath it Notification tone and Notification vibration respectively!)
  • Then enable, by tapping on this Notification vibration.
share|improve this answer
    
Yes, the settings is like that. But when I check vibration notification, it will vibrate when I get message, although I set in my notification bar sound mode, and I want it to vibrate only in vibrate mode. I want to set my phone to work like that if it is possible. I don't want every time when I turn sound mode to go to these settings and unchecking vibration notification –  Olivia Dec 31 '12 at 0:44
    
Right, correct me, you want to vibrate in silent mode upon receiving a SMS? i.e. no playing a notification sound, yet vibrate? –  t0mm13b Dec 31 '12 at 0:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.