Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

When I try to update my Nexus 7 from 4.1 (Jelly Bean) to 4.2 (also Jelly Bean) it works fine up to a point where the little android (with the rotating shape) lays down and has a red warning triangle with an exclamation point. When I press the power and VolUp buttons simultaneously to see what went wrong, the log shows this:

Verifying current system
Assert failed: apply_patch_check("EMMC:/dev/block/platform/sdhci-
tegra.3/by-name/LNX:5013504:c48f8e86e73fb2c2ba1794f5ec98e27c9e206ed5:
5060608:319331fae14fec8a88063751475fce26bae328e0")

I searched for the error message online and couldn't find anyone with the same problem. I even removed the random letters and numbers after "by-name" (I assume these are device-specific), and still found nothing. I also tried factory resetting and still the same problem.

I'd like to know what went wrong, and how to fix it.

share|improve this question
    
Why did you remove the random letters and numbers? They are part of a signature check to verify the update... probably the download got corrupted, was this OTA update? If so, you may have to re-initiate the OTA download again and retry. –  t0mm13b Jan 1 '13 at 22:30
    
I have downloaded and redownloaded probably 20 times. The update probably isn't being corrupted OTA. –  kylrth Jan 1 '13 at 23:48
    
disregard my last comment - something is wrong with the boot partition! Check the first posting over on XDA Notice that the block device name refers to the /boot partition... So my question to you is this, is the bootloader unlocked? –  t0mm13b Jan 1 '13 at 23:55
    
The bootloader was locked up until about 2 minutes ago. I'm going to try installing 4.2.1 with fastboot and see if that solves the problem. –  kylrth Jan 2 '13 at 0:00
    
Good luck :) Please do report back your findings :) –  t0mm13b Jan 2 '13 at 0:00
show 3 more comments

2 Answers

Q- What is an assert script?

A- All it does is check to make sure you are flashing the ROM on the correct device.

How to fix Android Custom ROM Status 7 installation Abort assert failed error in Recovery Easily [Ultimate Guide]: http://mobotechie.com/tips-tricks/how-to-fix-android-custom-rom-status-7-installation-abort-assert-failed-error-in-recovery-easily-ultimate-guide

Assert failed [SOLVED]: http://forums.androidcentral.com/optimus-v-rooting-roms-hacks/182438-solved-assert-failed.html

Thanks for those cool guys, and good luck.

share|improve this answer
add comment
up vote 0 down vote accepted

I don't really know what caused this problem. I had to unlock the bootloader and sideload with adb. This involved completely wiping my tablet. Here are instructions. Now my tablet updates just fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.