Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Possible Duplicate:
When will my phone get the Android 2.2 update (FroYo)?

if yes, how to upgrade it with out going service center.

share|improve this question
    
duplicate of: android.stackexchange.com/questions/2696/… –  Lie Ryan Dec 15 '10 at 8:56
add comment

marked as duplicate by Al E. Dec 15 '10 at 14:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers

up vote 1 down vote accepted

What model do you have? There are a billion (hyperbole) Galaxy S models. There is a 2.2 update for the US Captivate, for the international i9000, and for others.

You can get the update OTA (over the air) if you have stock (unaltered) 2.1, a notification will show on your phone (on most carriers). You can also download it through Samsung Kies (see my answer here). Finally, you can find an upload of it and flash it to your phone through a Windows tool called Odin.

You can also use ROM Manager to flash a custom ROM, which will get you 2.2 early if it hasn't been officially released yet. Search XDA if you want one of those ROMs.

share|improve this answer
    
I have SAmsung Galaxy GT-19000 –  Jeevan Bhatt Dec 16 '10 at 11:21
add comment

I have upgrade my Samsung Galaxy S from 2.1 to 2.2 without problems a few weeks ago.

If you connect your phone to the pc and start KIES, it should inform you if an upgrade is available.

share|improve this answer
    
Yesterday i was trying to update my galaxy s GT i9000, when i connect it to kies it shows message for to upgrade and the i clicked on firmware upgrade, it started with an progress bar and when it went to 100% it tried to reconnect mobile and the again it show "firmware available want to upgrade" and this time when i click on upgrade it does not any progress bar but tried to reconnect and then same message displayed. So basically i am not able to upgrade it. –  Jeevan Bhatt Feb 22 '11 at 10:16
    
@Jeevan Bhatt: Make sure you have the very latest of KIES installed. A previous version of KIES did not work on my pc either. –  Edelcom Feb 22 '11 at 10:55
    
yes i have latest. –  Jeevan Bhatt Feb 22 '11 at 11:12
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.