Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

There is an app that allows you to enter a secret code in the format *#*#(code)#*#*, however it is not working on my phone (Samsung Galaxy SII GT-I9100) running CyanogenMod 10 (Android 4.1.1).

I have managed to confirm that it is working on other devices, so why isn't it working on mine? Logcat reveals nothing.

share|improve this question

closed as off topic by Liam W, roxan, ce4, t0mm13b, Zuul Jan 6 '13 at 17:43

Questions on Android Enthusiasts Stack Exchange are expected to relate to Android within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Just so you know, I made/am making this app. This isn't a developer question however. –  Liam W Jan 5 '13 at 20:32
    
Just tested on my Mum's phone running 2.3.7 and it works fine! –  Liam W Jan 5 '13 at 20:58
    
possibly it only works on the Samsung's own dialer and not the CM version? –  t0mm13b Jan 5 '13 at 21:04
    
@t0mm13b Secret codes are built into Android, and are part of the dialer. Also, my mum has a SE, and it has worked on the emulator. I can also launch other secret codes (albeit they are all system ones) –  Liam W Jan 5 '13 at 21:12
    
Turns out this was a development issue... –  Liam W Jan 6 '13 at 13:13

2 Answers 2

A lot of the secret codes are either carrier specific or ROM specific. An example, I bought my son an HTC EVO 4G (from swappa) and called sprint to activate it. They had me enter one of the secret codes and it should have launched a window that would ask for a PIN. But it did not.

The reason was because the phone that I bought was running CM7. In order to activate I had to enter this code. But in order to enter the code, I had to have the Stock HTC Sense ROM installed on the device.

I found a flashable version of the Sense ROM, flashed it, called back Sprint and entered the Secret Code. Everything worked as expected. Then after the device was registered with Sprint I flashed CM7 back on the device.

share|improve this answer
1  
Urgs, is CDMA registration really this dreadful? –  ce4 Jan 5 '13 at 23:10
    
@ce4 CDMA? Whats that... –  Liam W Jan 6 '13 at 10:49
    
@ce4: there is most probably a platform/device independent way to register the device, perhaps by manually entering some settings, but the customer supports's script probably does not include that since they don't want to support modded devices. –  Lie Ryan Jan 6 '13 at 11:38

Ok, so I discovered what the issue was...

It seems that it only works if the app is a system app - I have no idea why, as it works normally on my mum's phone running Android 2.3.7.

It must either be an Android 4.1.3 feature, or a CyanogenMod feature. I will investigate further however.

EDIT:

This wasn't actually the issue. It turns out it was a development issue, as apps needed to be opened first (on Android 3.1+) before the receivers would register.

share|improve this answer
    
A system app is signed and part of the ROM, you need the keys to sign the app and shove it into /system/app, in nutshell, a system app will have more access to Android's intents that are specific to system. A ordinary app would not have that privilege - for example secure settings.. –  t0mm13b Jan 6 '13 at 16:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.