Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a Milestone and I only want my Google contacts to appear in the contacts list, on my phone. The native (corporate)'email' app is synced with my work email (Microsoft Exchange) and calendar; this works great apart from one irritating problem... Even though I have unchecked the 'sync contacts' option from within the 'email' app and from Contacts>Menu>Accounts>Corporate A/C options (though I presume both options are the same single setting) my work contacts are pulled into my overall contacts list, anyway!

Twice I have deleted all of my outlook contacts (from my PC) and ALL of the contacts from my phone. After re-syncing the Google contacts and being certain that I didn't check the option to sync my Outlook contacts, low and behold the outlook contacts would start to appear through the course of the day (once I put them back on the PC).
Any suggestions as to why this is happening or, even better, how to fix it?

I understand that the MS exchange sync component was written by Motorola, so maybe this is interfering with the contact sync? Anyone not use the calendar sync and still have this issue?

share|improve this question
add comment

1 Answer 1

I stopped using the Corporate Email app that came with my Droid because of stability issues and reasons like this. I got TouchDown (AppBrain) for my work MS Exchange email and haven't looked back.

I realize this doesn't offer a solution to your problem's symptoms, but it would solve your main problem by avoiding the inferior Exchange app all together.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.