Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

A friend recently bought a Blusens Touch 96 tablet as a Christmas present for her father. The specs are here. Short version: 9.7 inches, Android 4.1, Cortex A9 processor, 1 Gb. RAM.

Anyway, the tablet looked responsive and reasonably fast when tried in the store (opening apps, scrolling, etc.), but when he tried to connect to the WiFi network things started to go wrong. The tablet was incredibly slow when doing anything online: it took us about an hour and 3-4 timeouts just to create a Google account.

The simplest webpages take about 5 minutes or more to load. Meanwhile, and just as a test, I was trying to access the same pages with a laptop at my side, and there were no problems. All of this in the same room than the Wifi router, at less than 5 meters of distance.

We tried restarting the Wifi router, disabling autosync in the Google account (as per this post) and restarting the tablet, but nothing seemed to work. My friend is understandably miffed.

My question is: is this a "normal" experience with a cheap, unknown-brand Android tablet? I have to admit that I don't own a tablet myself and don't know much about this market. I knew not to expect too much from cheap chinese-knockoff style products, but even this seemed too much for me.

share|improve this question

closed as not a real question by Matthew Read Jan 8 '13 at 3:46

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Might be best to provide an attachment of the dumpsys obtained via adb shell dumpsys and a screenshot of the About menu via Settings > About... oh! and also a logcat, when connecting to the WiFi. It could be flaky wifi support possibly a firmware update? –  t0mm13b Jan 7 '13 at 23:41
    
That looks like a wifi issue solely, do you have many competing networks and a crowded spectrum at your location? Or are you maybe in a blind spot or close to being out of range? Try to move closer to the router and retry. The router may also be the reason. Maybe cross try another wifi net. PS: There's also the 'wifi analyzer' app to find signal problems. –  ce4 Jan 8 '13 at 0:27
    
Tablet does not like the Wifi channel that the router is broadcasting on? –  t0mm13b Jan 8 '13 at 2:27
    
It should obviously not be expected but cheap stuff is cheap. If you'd like to ask how to solve the issue please feel free. –  Matthew Read Jan 8 '13 at 3:47
add comment

Browse other questions tagged or ask your own question.