Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Just got a Samsung Galaxy S3 mini with Android 4.1.1 factory installed. The phone is not locked to any carrier. My problem is that I can not for the life of me find the setting to turn on the haptic feedback, neither for the keyboard nor other touch events (such as the menu button, etc.). I've looked through the settings menus several times without finding anything.

The actual vibration hardware is working, because if I go to Settings -> Sound -> Device Vibration it vibrates.

The only other mention of this issue I've found was one unanswered thread on the Samsung Galaxy Forums.

This is the kind of thing that makes me wonder if Google (and others) are actually trying to make things worse with every update. My HTC Nexus One running Android 2.3.6 never had any oddities like this. Only problem with that old phone is it's limited internal memory.

share|improve this question
    
Have you turned keyboard vibrate on? System Settings, language and input, android keyboard clock the little settings icon on the right, vibrate on key press checked. –  Liam W Jan 8 '13 at 22:36
    
See this Post #7 seems to be the only fix so far, provided your are rooted, However, there's this app on Play Store that may just do the trick for you. –  t0mm13b Jan 8 '13 at 22:43
    
Thanks, now I at least have vibration in the keyboard. It turns out the stock Samsung keyboard does not have a vibration setting, and the phone comes without the Android keyboard. I ended up installing my trusty old Smart Keyboard Pro, now I have both vibration and arrow keys for moving the cursor (my old Nexus One had a trackball for this). Seems I'll have to live without system wide haptic feedback though, which really is a shame. It seems that every update introduces more bugs than fixes... sigh... –  BadCash Jan 9 '13 at 4:12
add comment

3 Answers 3

I finnaly found it and I hope it helps:

Unless you already did so, go to Settings→Language and Input, tap the setting icon on Samsung keyboard, go to Advanced, and uncheck Vibration and Sound -- depending on which one you want!

This works for the jellybean update ok 4.1.2 . Hope I helped!

share|improve this answer
add comment

System Sounds > vibrate on touch.

share|improve this answer
add comment

In some versions of Jelly Bean the setting for activating haptic feedback is hidden. But there are a couple apps that can be used to enable it:

(Source)

share|improve this answer
add comment

protected by Community Sep 8 '13 at 15:07

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.