Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

For some reason I have 10 contacts in my Google Contacts account, but I have 50 contacts on my Android phone. I have signed into my Google Account from my Android phone and I have enabled

settings > accounts & sync > background data
settings > accounts & sync > auto-sync
settings > accounts & sync > oshirowanen@gmail.com > sync contacts

Why are my contacts not syncing?

I have tried switching my phone off and on, and I have also tried deselecting and then selecting

settings > accounts & sync > oshirowanen@gmail.com > sync contacts

to force a sync, but nothing has worked so far.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

All contacts that have a group will sync. Those contacts that don't have a group (ie "Other Contacts") will not.

Go to Gmail on a PC and choose contacts (I haven't tested from a phone). There is a default group called "My Contacts" and there is a default group called "Other contacts" I would guess you don't have any or very few in "My Contacts".

Open a contact and make sure they are assigned a group. Either "My Contacts" or a custom group underneath that.

This way you can still have contacts in Gmail without having them in your phone. BTW anytime you get an email and the contact is new, it is put in "Other Contacts".

share|improve this answer
    
And again learned something new -- thanks for sharing this! –  Izzy Jan 10 '13 at 21:47
    
Thanks, I am selecting a contact on my phone, and choosing Add to group, but get a message saying No groups. But I have 5 groups on my phone Starred in Android, Coworkers, Family, Friends, My Contacts. All under the Google System Group section on my phone. –  oshirowanen Jan 10 '13 at 21:48
    
Moving the contacts from google contacts on my computer to a group synced the contacts so they now appear on my phone, but the 50 contacts on my phone are still not appearing on my google account via my computer. –  oshirowanen Jan 10 '13 at 21:51
    
And from my experience, the contacts from the phone will not sync to google. This will have to be done by typing them into gmail contacts. Make the conversion. Join the collective. –  William Jan 13 '13 at 11:00
    
But wait! after looking in the google play store there are a few apps that promise to do just that. Here is one that looks promising. –  William Jan 13 '13 at 11:23
add comment

Yes, when you save a contact in the PEOPLE app it will ask you to save it to "phone" or "google/gmail". If the contact is saved in the "phone" part, it will not sync.

share|improve this answer
    
I don't get such an option, all I get is import from sim to phone. I don't get an import from sim to google. –  oshirowanen Jan 13 '13 at 9:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.