Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I rebooted my Logitech Revue today by pressing ctrl+alt+delete, which I have done a number of times before. After it went through the normal boot up it went to a blank screen. And just stays there, unresponsive. The remote does nothing for any of the other devices either as it seems that the "universal" part of the remote is actually software based, not in the remote itself.

I figure that I should be able to reset the device back to factory defaults but not sure how to reset it. I am hoping that a reset will get the device working correctly again.

share|improve this question
add comment

1 Answer 1

up vote 3 down vote accepted

You can try to press and hold the Pair/Reset button on the back of the Revue for 10 seconds.

Source

Using the hardware button

Press and hold the Pair/Reset button located to the left side of the left HDMI port on the back of the box for about 10 seconds. The Revue will then restart with factory default settings.

Using the menus
1. From the home screen select Applications.
2. Choose Settings.
3. Select About.
4. Choose Factory data reset.
5. Select Reset device.
6. Select Erase everything.

The Pair/Reset button is the one identified by number (1) on page 3 of the Logiteh Revue manual.

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.