Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I bought a locked Samsung Galaxy S2 second hand - it is locked to Vodafone.

When I first purchased it worked fine, however yesterday morning it couldn't connect to the mobile network - it kept saying:

Cannot connect at this time, try again later

I have backed up and reformatted my SDCard, as a Mac would read it but when I put it into my SGS2 it kept on saying "Scanning Media" and all the storage values were greyed out.

Is there any way I can fix this issue? I have tried Vodafone's customer services, but they were less than helpful. All they recommended was to change the SIM, reformat, reset the phone and start again, which I have done, including a hard reset -- but the problem remains.

Any ideas what else could be done to get it working again?

share|improve this question
    
As it looks like, there are only two things were it could go wrong: Either the SIM card, or a hardware problem with your SGS2. If you can do phone calls, but just not go to the net, it also could be the APN settings. Have you tried a different SIM in that device? I'd recommend you to go to a Vodafone shop and try exactly that (they should have some SIM to test, and also could verify the APN settings). If all that fails, most likely it's an hardware problem (all else should have been eliminated by the hard/factory reset). –  Izzy Jan 19 '13 at 14:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.