Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This happens constantly:

  1. Go to Data Usage->"Mobile Data" to "On".
  2. Lock phone for about 30 min.
  3. Unlock phone and try to use an application that requires data connection.
  4. The application says no connection (not application specific, happens with Waze, Play Store, Evernote, Remember The Milk...).
  5. Go to Data Usage->"Mobile Data" is "Off", turn to "On".
  6. ...[cycle repeats]

My setup:

  • Galaxy S2
  • Resurrection Remix 3.8 ROM
  • JuiceDefender Ultimate

If I check JuiceDefender before step 5 above, it says "Data Off (User)", i.e. JuiceDefender thinks that I switched Mobile Data off. So it's not JuiceDefender's fault.

Something else is switching Mobile Data off (and I can't find any setting to leave it on). What could it be and how do I stop it?

share|improve this question
Might be you've got another app installed that deals with it? I'm no prophet, so I don't know about your installed apps ;) But what I'd try first is disabling JuiceDefender and check if the problem goes away. If not, go through all your apps looking for potential candidates (especially automating apps like Tasker or Llama, Phone Profiles and what else is available). Check their settings one-by-one, disable them one-by-one (so you can be sure which one caused it), enable them again if they were not the cause. – Izzy Jan 19 '13 at 14:12
Except JuiceDefender, I don't have any other automation apps. Tried to disabled JD from yesterday and it didn't help. – XAMeLi Jan 20 '13 at 14:56
Android version 4.x? Have you checked your settings for mobile data? ICS introduced a manager here which can turn data off when your configured limit is exceeded. – Izzy Jan 20 '13 at 15:11
Checked it and the CheckBox is not checked, i.e. I don't have a limit set. – XAMeLi Jan 21 '13 at 10:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.