Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I enabled my laptop as a hotspot and connected my tablet through WiFi. Then I turned WiFi on and it shows me the network but it tells me I'm not in range.

After that it shows network disabled and poor connection. How do I get over this?

share|improve this question
    
It would help to know what you used on your laptop to create the WiFi hotspot. Could it be the software used only provides Ad-Hoc access? This is currently unsupported by Android, though it's on the wishlist for years... –  Izzy Jan 20 '13 at 11:30
add comment

2 Answers

If the hotspot ssid shows in your Android device means, definitely it wont be an Ad-Hoc network. Most probably the the problem would be getting DHCP ip from your laptop. Try giving static ip to both hotspot network and your android device.

share|improve this answer
add comment

Go to Wifi Settings > Advanced > Uncheck the option titled "Avoid poor connections".

That will probably get rid of the "Poor connection prompt."

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.