Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have to press the refresh option in Gmail just to get new messages.

I have checked the application and the notification setting is on. I stopped it and then again started it but still it is not working. Is anyone else facing such issue? Android version is 4.2.1

In my accounts it is showing that "Sync is OFF". Has this something to do with this? I always see this option like this and have to go inside it to change Gmail, Currents, Photos, etc. to sync.

share|improve this question
    
If in your accounts Sync is turned off, that's normal behaviour. Turn Sync on if it should retrieve new messages automatically -- that's what Sync is for. –  Izzy Jan 20 '13 at 23:54
    
Thanks. Actually there was no option coming for setting the Sync on, so i have to remove the account from the device and added it again, now it started working. –  Sudarshan Jan 21 '13 at 0:23
    
That's strange. Usually one goes to Settings->Accounts & Sync and can switch Sync off and on again there. Anyhow, as you've solved it (congrats;): Feel free to add your own answer below to show there's a solution for others to find! –  Izzy Jan 21 '13 at 7:01
    
I found this link which solved my similar issue. It walks you step by step on possible solutions. Mine got solved by removing the cached data of the Gmail app and restarting the phone. Note that this will erase your settings such as signature and notifications settings. I couldn't post an answer for some reason so I'm posting as comment ... The link - Problems syncing Gmail on Android - support.google.com/mail/troubleshooter/… - Good luck! –  Mario Awad Jul 26 '13 at 8:53
add comment

2 Answers

On stock Android 4.2.2 on my Galaxy Nexus I had the same problem of gmail notifications not working. I checked that in Settings>Data Usage "Auto Sync" was turned on.

Then I went to Settings>Accounts>Google, hit the email address and you see everything that is being synced or not.

Weirdly for me it Gmail sync was inactive after I had recently updated my rom.

This should take care of this problem.

share|improve this answer
add comment

I recently ran into this issue with my phone after downloading a Battery Saver app that I noticed had turned sync off after I had uninstalled the app.

I read through all the comment answers above and no one came close to the Stock ROM 4.2's data sync setup. In the (current at time of post) latest Version of Android the "Accounts & Sync" has been removed and all accounts are inline in the Settings ListView.

Individual Accounts will only let you sync now, there is no option to "Turn Sync on" or "Auto Sync"

My setup:

Verizon Galaxy Nexus
Android 4.2.2 Stock ROM
Build Number: JDQ39

What I did to resolve:

Go to Settings->Data Usage->Menu->Click Auto-sync data

share|improve this answer
add comment

protected by Community Jun 20 '13 at 15:12

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.