Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I am following a Wiki on how to install and set up Android SDK and I am stuck at a step where I am supposed to test if the ADB server works by using the command adb start-server. Is this command correct?

The Wiki can be found here: http://wiki.rootzwiki.com/Android_SDK

I have done what it says in step 5. But it doesn't seem to work. I get the standard message in CMD that the command is not an internal, external command or a program.

Add the following to the end of the Variable value field:

Windows XP: ;C:\Program Files\Android\android-sdk\tools\;C:\Program Files\Android\android-sdk\platform-tools\

Windows Vista and later: Replace YOURUSERNAME in the following lines with your Windows username

32-Bit: ;C:\Program Files\Android\android-sdk\tools\;C:\Program Files\Android\android-sdk\platform-tools\

64-Bit: ;C:\Users\YOURUSERNAME\AppData\Local\Android\android-sdk\tools\;C:\Users\YOURUSERNAME\AppData\Local\Android\android-sdk\platform-tools\

Click OK, OK, and OK to close the Advanced settings.

So what gives? The CMD prompt is at C:\Users\myusername when I run the command. Maybe I need to CD to the android-sdk folder first before running the command? But then what use is it to add the path in the PATH variable?...

share|improve this question
1  
After you add variables to the system you need to close the command window and open a new one. if that still doesnt seem to allow you to do adb commands, make sure the path you are adding is the path that you actually installed the SDK to. –  Ryan Conrad Jan 24 '13 at 21:47
    
The reason to add the path into the $PATH variable, which btw, is system-wide, so no matter where you are in the command line i.e. CMD, adb will work regardless as windows knows where the actual adb binary resides in. –  t0mm13b Jan 24 '13 at 21:51
    
Yes, but I don't get this part where you're supposed to replace YOURUSERNAME with the actual user name of the account. I used default installation location on C drive and I installed it on a 64-bit system. –  sammyg Jan 24 '13 at 22:02

3 Answers 3

up vote 3 down vote accepted

I have solved my own problem. Those search paths are all messed up!

I checked the installation path and it's installed in C:\Program Files (x86)\Android even thou I do have a 64-bit version of Windows. But nevertheless, this is the default installation location.

So I updated the PATH variable with following line.

C:\Program Files (x86)\Android\android-sdk\tools\;C:\Program Files (x86)\Android\android-sdk\platform-tools\

And now I can start ADB server from CMD regardless of where the prompt is at.

Android SDK ADB server in CMD screen

I have no clue why they are referring to AppData\Local\ folder in the guide for the 64-bit systems. That makes no sense at all. If anywhere, the installation location should be in "Program Files" folder for a 64-bit system. They actually put this in for the 32-bit systems... like I said, it's all messed up.

I should point out that adb.exe has been moved from C:\Program Files (x86)\Android\android-sdk\tools\ to the new location C:\Program Files (x86)\Android\android-sdk\platform-tools\. This has been done in later versions of Android SDK.

So if you are reading this in year 2013 then you can probably just get the latest SDK and use only this last search path. You don't need them both. At least not for ADB and Fastboot. If you're a developer then you maybe need to access tools from both directories, although if you're a dev then you probably won't need to read this at all.

How to edit a system variable

Here's a short how-to for the newbies. What you need is the Environment Variables dialog.

  1. Click Start (Orb) menu button.
  2. Right click on Computer icon.
  3. Click on Properties. This will bring up System window in Control Panel.
  4. Click on Advanced System Settings on the left. This will bring up the System Properties window with Advanced tab selected.
  5. Click on Environment Variables button on the bottom of the dialog. This brings up the Environment Variables dialog.
  6. In the System Variables section, scroll down till you see Path.
  7. Click on Path to select it, then the Edit button. This will bring up the Edit System Variable dialog.
  8. While the Variable value field is selected, press the End key on your keyboard to go to the right end of the line, or use the arrow keys to move the marker to the end.
  9. Type in ;C:\Program Files (x86)\Android\android-sdk\tools\;C:\Program Files (x86)\Android\android-sdk\platform-tools\ and click OK.
  10. Click OK again, then OK once more to save and exit out of the dialogs.

That's it! You can now start any Android SDK tool, e.g. ADB or Fastboot, regardless of what your current directory is in CMD. For good measure here's what the dialog looks like. This is where you edit the Path variable.

environment variables

share|improve this answer
2  
The location where binaries on Windows are stored is determined by the type of the binary and not by the running Windows version. That is, a 32-bit binary will be installed in Program Files (x86) and a 64-bit binary will go to Program Files. Therefore the SDK installer uses the correct location. –  Flow Jan 24 '13 at 22:40
    
Good point! In other words the Android SDK is 32-bit so it installs to the 32-bit (x86) program folder. Which is why that part of the root guide that gives instructions for 64-bit systems makes even less sense then. –  sammyg Jan 24 '13 at 22:44

instead of looking for a default location simply look for platform-tools\ and android-sdk

or just sdk

those are the paths you need to add to the variable list

share|improve this answer
    
Yes, and where do I look for platform-tools and android-sdk? On my desktop?... –  sammyg May 22 '13 at 10:43
    
My point is that you have to look for them some place. Right? And what's a better place to start with than the default installation location? And just to be clear, we're not looking for any SDK folder that pops out! We're looking for the one used by the Android SDK. So I'm not gonna use file search to find any random folder called 'SDK' to put in my Path variable. Remember, you have Java SDK installed too if you have Android SDK (and probably others too if you're a developer). You don't want that SDK folder. –  sammyg May 22 '13 at 10:56

Just add this to System Variables "Path":

C:\Program Files (x86)\YOUR_ADT_FOLDER\sdk\platform-tools\

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.