Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Samsung Galaxy S2 I9100 is rooted + 3rd party Jellybean 4.1.2 XXLS6 MIUI rom

Music apps tested: DoubleTwist | Songbird | Google Music

In all of these apps, the music list shows empty.

I have tried:

  • Reboot recovery & "fix permissions"
  • Launching music files directly from File Explorer (WORKS)

I have a feeling it may be partition or mounts or permissions related. That the apps just can't read the file-system or something?

Can anyone suggest what other things I can try?

share|improve this question
Is there a .nomedia file in your music folders? – Liam W Jan 29 '13 at 22:24
Nope :( Wish it was that easy! – pablorenato Jan 29 '13 at 22:32
Please try and clear the data for the media storage app, your music apps and reboot. – Liam W Jan 29 '13 at 22:35
tried this too, no luck – pablorenato Jan 30 '13 at 3:10
It appears there is an issue with the media scanner in Samsungs Jellybean base rom. – pablorenato Jan 30 '13 at 5:08

If you are rooted and have a 3rd party ROM that has not been tested, it might be a bug or a glitch, I would contact the developer.

share|improve this answer
This problem this appears to be an issue with the "Media Scanner" function in Samsungs jellybean rom for i9100. – pablorenato Jan 30 '13 at 5:06

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.