Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Both my Motorola Bionic and OG have bad audio jacks that require significant jiggling around to get a constant connection almost every time I plug them in. Once it's "good" I can leave it alone and it works great but if I bump the connection it could disconnect again.

Is there any resolution to this? Is this true for other phones as well? It doesn't matter what OS version, it's the hardware connection itself.

share|improve this question
    
This may be too localized to you, as I had no problems with my OG Droid. However, are you sure it isn't your pair of headphones? Did you try different headphones with the devices? Or was it the same headphones between both phones? –  Dylan Yaga Jan 30 '13 at 19:28
    
Many different cables/headphones that all work fine on the other end or on other devices. It's the jack itself. –  Enigma Jan 30 '13 at 19:31

1 Answer 1

up vote 0 down vote accepted

The jack is probably dirty, or the wires could have loose connections in the phone. Try cleaning the headphone jack.

share|improve this answer
    
Using a compressed air can is all I can think of which I've tried already to no avail. My guess is that the connectors are not pushed forward as much as they should be. Is there a way to replace the connector or do I have to get a needle/pin and try to bring them forward? –  Enigma Feb 1 '13 at 15:17
    
There was dust that was compressed and stuck all around the edges which was impossible to see or get out with compressed air. The connection is solid now though. –  Enigma Feb 15 '13 at 15:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.