Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I want to work with 1024MB or higher RAM sizes but when I try to start my Virtual Device it is giving the error:

Failed to allocate memory: 8

I researched many thing about this issue;

Some releated solutions are;

  • Manually change the AVD's .ini files etc.
  • Run emulator as Administrator
  • Run from commant line

All of them did not work for me.

My system is:

  • 64bit Windows 7
  • i7 3610QM CPU
  • 8GB RAM
  • 2GB Graphic card

Android 4.2 is the version that I am trying to use.

share|improve this question
    
What is your Eclipse version? This seems to be a problem with Eclipse after upgrading to version 20. It may be a bug, see here Android Issue 33930: Emulator stops working after upgrading to version 20 –  Akhil Jain Feb 1 '13 at 15:42
    
@AkhilJain i'am using Eclipse Juno - Eclipse Java EE IDE for Web Developers. Version: Juno Service Release 1 Build id: 20120920-0800 –  hakiko Feb 1 '13 at 22:55
1  
You may want to recreate the virtual device with more memory. –  Devyn Collier Johnson May 13 '13 at 18:20

1 Answer 1

In the 'Create new Android Virtual Device' window in Eclipse it says, "On Windows, emulating RAM greater than 768M may fail depending on the system load. Try progressively smaller values of RAM if the emulator fails to launch."

As answered here http://stackoverflow.com/questions/8853541/why-cant-i-boot-an-avd-from-eclipse-with-1024-mb-of-ram, there is a .ini file you can edit in [username]\.android\avd[avd name.avd]\config.ini that you can edit by changing 'hw.ramSize=1024' to 'hw.ramSize=1024MB'. I tried it and it worked for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.