Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I recently updated to the 10.1 M snapshot of CyanogenMod for my Sprint Galaxy S3 (d2spr). Ever since I did the update, I have been seeing crazy high battery usage from Google Services. I have tried just about everything I can think of to shut it off, but nothing seems to be working. I'm connected to Wi-Fi most of the day, so I don't think 3G has anything to do with it.

Attempted Troubleshooting:

  1. Turn off Google Account Sync (per this question)
  2. Turn off Google Now
  3. Turn off Location reporting

If possible, I'd like to fix this without using Juice Defender or any other battery management apps, but if that's what it takes, so be it.

So how can I get Google Services to stop sucking the life out of my phone?

Google Services - 37% Google Services detail - keep awake 2 hours

share|improve this question
    
Please take a look at Google Services is killing my battery by keeping phone awake. Comparing the descriptions, ut looks exactly like your problem (updated my answer below accordingly). –  Izzy Feb 2 '13 at 22:56
add comment

1 Answer 1

up vote 4 down vote accepted

This is most likely some app utilizing Google Services. You don't show the details screen to be reached when tapping the graph on top of your first screenshot. Please check there, and cross-check with How to deal with (orphaned) WakeLocks? -- the "keep awake" of your second screenshot suggest Wakelocks as the "source of evil". The part What if it is the Android System itself? should help you track the issue down further.

Another possible -- no, very likely candidate is found in another question I just stumbled upon: Google Services is killing my battery by keeping phone awake. Sound familiar? ;)

share|improve this answer
    
Following up, I used BetterBatteryStats to uncover that it was, in fact, location services sucking the life out of my battery. I turned off location services via Settings -> Location Access. This has the unfortunate consequence of disabling Google Now. But for now, at least, it looks like it is one or the other. –  Ryan Feb 18 '13 at 19:25
1  
Oh -- that turns Google Now off? Good to now -- thanks for mentioning that feature :) Btw: If you follow the first mentioned link, you'll find another link to an article explaining how to find out who's really behind it (which app is causing location services to suck your battery). So you can kill that app, turn location access back on, and enjoy Google Now. Unfortunately, this will require root AFAIR... (Pinpointing Android LocationManagerService battery drain) –  Izzy Feb 18 '13 at 20:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.