Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using my own SMTP server with SMTP AUTH for sending mails. The greeting looks like:

250-[...fqdn...] Hello [...fqdn...] [...ip...], pleased to meet you
250-ENHANCEDSTATUSCODES
250-PIPELINING 250-8BITMIME
250-SIZE
250-DSN
250-AUTH CRAM-MD5 DIGEST-MD5
250-DELIVERBY
250 HELP

Unfortunately when configuring user name and password for SMTP (no TLS), Android 4.2 (the standard mail app of the Google/LG Nexus 4) does not seem to expect this: authentication methods aren't supported by server.

On the server, I see Android disconnecting after that greeting was sent.

What authentication methods are actually supported by Nexus 4's mail app?

share|improve this question
2  
I didn't look at the logs of my server for this, but I am using CRAM-MD5 myself with K9 mail. So it's definitely not the fault of Android, but rather of the mail app you're using. Maybe you could add information on your device, as different manufacturers might use different "stock email apps"? – Izzy Feb 6 '13 at 10:29
    
@Izzy: It's the Google/LG Nexus 4. After your comment I tried K-9 and it is working. Thanks a lot. Adjusted question accordingly. – undur_gongor Feb 6 '13 at 11:39
1  
Glad the hint helped! So as suspected, it is a limitation of the pre-installed mail app of your device. Thanx for updating the details -- with some luck another GN4 user might be able to help on this. – Izzy Feb 6 '13 at 14:08
    
Do you mind adding a few screenshots of your configuration window. In those, the text areas like username, password and server could left blank meanwhile keep other options as they were and take the screenshot. – The Dark Knight Feb 10 '13 at 19:11
    
@Murshid: It seems screenshots require rooting the phone which I did not do (yet?). However, the configuration for SMTP consists just of the following fields: server -- [...], port -- 587, security type -- none, require sign-in -- yes, username -- [...], password -- [...]. – undur_gongor Feb 10 '13 at 19:52

Probably a bit late to the party, but I'm recording this here for posterity. My wife's Xperia Z5 Compact (Android 5.?), as well as my own Samsung S3 (4.3) suffer from this same problem. I've pulled down the source code to the most recent email client, and it appears that the only authentication mechanisms that the native email client supports is PLAIN, LOGIN and XOAUTH2, otherwise the client comes up with the above error message. As noted in the OP, the mail server is only offering CRAM-MD5 and DIGEST-MD5, which the client doesn't support. I had to add PLAIN and LOGIN to my mail server (after enforcing TLS), at which point the stock mail client was happy.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.