Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have Galaxy S3 GT-I9300 version 4.1.2 and I lost the "Accounts and Sync" under settings. I added the "Auto sync data" under Data usage and it still does not sync automatically with my calendar. My question are:

  1. How can I restore the "Accounts and Sync" ?
  2. How can I control Auto sync mode on each application?

Thanks

share|improve this question
    
I found a Sync option under Data Usage only –  yaira Feb 6 '13 at 14:59
    
Then you're using a custom ROM, not stock ROM... –  Peter Feb 6 '13 at 16:31

5 Answers 5

Android 4.1.2 doesn't has an Accounts and Sync option under settings, it just has the text Accounts, each of your account in a row (if you have any account added to the device) and the plus sign at the bottom to add more accounts.

"Auto sync data" MUST be enabled. Go to "Settings > Data Usage > Click the MENU button on your device > Check "Auto sync data."

Autosync for each application is under each application menu. For example, if you have your google account configured, you have to select Google > and there you will see the sync options. In this case you will see sync calendar, contacts, etc and their respective checkboxes to enable/disable them.

Check the screenshots/steps to get there:

  1. Go to settings > accounts and click the one you want to setup.

    Account Settings

  2. Once inside, click on the account name with the sync icon.

    Google account

  3. You will see the sync options for that account.

    enter image description here

share|improve this answer
    
No check option under Accounts. I found this options under "Data usage", only if I checked "Auto Sync data" –  yaira Feb 6 '13 at 14:56

While Peter's answer is correct, there's more to the story, at least on 4.1.1. I know the OP says 4.1.2, but I add this in case some or all of it is the same in 4.1.2, or for the sake of anyone with 4.1.1 who happens by this question.

There is a global Sync setting available in the notification panel widgets. It's all the way to the right (you'll have to scroll the widgets to see it):

Notifications showing sync

From what I gather, this isn't there in 4.1.2, unless you reconfigure the notification switches to put it there. The tricky thing is, you can get there another way, as indicated in the OP. This option is also available by going to Settings -> Data Usage and tapping the menu button:

Data usage menu

This is an awful design, in my opinion. But that's the way it is. What you see in the items under Settings -> Accounts can change based on whether or not Auto sync data is turned on. For example, with it switched off, the Google account sync options look like this:

Google sync settings with auto sync on

and with it switched on, they look like this:

enter image description here

So, to make sure that your phone will automatically sync with your Google calendar, you need to enable Auto sync data and then check Sync calendar under the Google account sync options (because the check box won't be there until you turn Auto sync data on).

share|improve this answer

I found the answer (whether it's the best way to do it I'm not sure!)

I removed the Google Account and re added it.

It asked me to sign in and once I had, a page came up where I could tick or untick each part of google that I wanted to sync, ie: email, contacts, calendar, internet, books etc....

it all seems to work now!

Paul

share|improve this answer

I just had the same issue.

The first answer won't work if you updated from 4.1.1 to 4.1.2, while having sync toggled off.

The simplest solution is to add the sync button again in the notification panel. Then, toggle it on from there.

The settings to modify the buttons in the notification panel (panel at the top of the phone) is under Display > Notification panel. Drag and drop the icon into the notification panel after removing unwanted icons.

share|improve this answer

Sync can be turned on from the pull down menu (windowshade) from any screen. I just found it.

share|improve this answer
    
Are you talking about the simple "master switch" to switch on/off sync completely? That's not what the OP asked for. As I understood, the question concerns the configuration section where you can deal with the accounts/apps separately (see the last screenshot in Peter's answer). –  Izzy Mar 29 '13 at 11:04

protected by Community Apr 15 '13 at 21:05

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.