Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I got a Samsung Galaxy 3 GT-I5800 with Android 2.1. Installed Skype on it, and when connected to wifi it works. When WiFi is not available it switches to G3. While I use the phone, skype works fine. If the phone sleeps/locks, no one can call me from their PC. I think it's because skype disconnects when the phone sleeps and logs-in as soon as I activate the phone touchscreen.

What do I need to do, to get Skype to work and receive calls at all times?

share|improve this question
    
Could you confirm that Skype stays connected when using 3G (wifi connection turned off) and the phone is not on sleep? Can you make Skype call over 3G? –  jmbouffard Feb 2 '11 at 12:28
add comment

3 Answers

Android shuts of WiFi after a certain time by default, sometimes as little as 15 seconds after the phone is locked. To change the timeout period, go to:

Settings -> Wireless and network -> Wi-Fi settings

Then press the menu button, choose Advanced, and change the Wi-Fi sleep policy to "Never".

share|improve this answer
    
I don't believe this would be a solution because Skype should stay connected even on 3G. The only thing I could think of is if his provider blocks Skype from its 3G network. –  jmbouffard Feb 2 '11 at 12:30
    
@Matther Read you forgot to mention that after setting Wi-Fi sleep policy to never, you need to press the menu button again and then Save –  user1648 Feb 2 '11 at 14:34
    
@YuriKolovsky I don't think I even have that option, it isn't needed on my Galaxy S anyways. –  Matthew Read Feb 2 '11 at 20:12
add comment

Turn off any Battery saver app, As I selected the wifi sleep mode to NEVER, but it kept switching off, I then uninstalled the Battery saver app .. Voila now skype works un-interrupted.

share|improve this answer
add comment

Normally Skype should stay connected on both networks, wifi or 3G. And it should also stay connected when your phone goes to sleep. So there are two things that could be your problem:

1- Maybe your provider is blocking Skype from the 3G network, in this case follow @Matthew Read answer:

Settings -> Wireless and network -> Wi-Fi settings -> Then press the menu button, choose Advanced, and change the Wi-Fi sleep policy to "Never".

2- Make sure that the background data usage is enabled in Settings -> Data Synchronization -> Background data. If not, applications are not allowed to use data while the phone is on sleep.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.