Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

My S3 (Jellybean) was suddenly no longer recognised by my PC when plugged in via USB. I solved that by debugging using Developer Options as advised in another thread, which allowed the driver to be installed... again (thank you).

But now if I try to use it as a hot-spot via USB tethering, I'm prompted to enter a network security key.

Previously it just connected without the need for this and furthermore, I don't know where I would find such a key since I didn't set it up in the first place.

Help anyone?

share|improve this question

3 Answers 3

Once you have activated tethering you can select the "Portable Wifi hotspot" row on the left side in the tethering menu to get an information page. From the information page there is a configuration menu to add specific allowed devices to connect, and to configure the SSID and password of the tethering Wifi Hotspot.

I find this is confusing/misleading because in the same row there is also the tethering activation/deactivation button on the right side so to me it is counter-intuitive that other elements in the same row would also have actions associated with them.

share|improve this answer

Go to setting > more settings > tethering now enable tethering. On same screen tap tethering again, not to turn off, so tap to the left of the tether on switch. A screen opens, go to bottom left corner and tap configure. Scroll down you will see a password field, tap the show password then copy and paste the password to notepad or write it down. When your laptop asks for a security key enter password. I did this for the first time in ten minutes.

share|improve this answer

I don't think you can use hotspot through USB. May be it is asking for your wifi hotspot password. Which you can find in 'Tethering and Portable hotspot' settings.

share|improve this answer
    
You definitely can, because I was doing it up until today! Like with my old iPhone 3GS, I just plugged it in and it was available in the Network and Sharing Center. However, whereas the iPhone automatically became a hotspot when tethered, with the S3 each time you go to settings and switch on the 'Tethering and portable hotspot' & it warns you that the Wifi will then be turned off. It's only today that it needed a password. I can't see any settings in 'Tethering and portable hotspot' apart from the slider to switch it on, USB or Bluetooth tethering and Help (which isn't). –  user28076 Feb 7 '13 at 20:20
    
Well, I am sorry about my earlier answer. Since I didn't use USB tethering I didn't know about it. Since I am on a custom ROM, I couldn't figure the exact problem of yours in my mobile as well. So, I thought of giving you some alternatives, Try this PdaNet, junefabrics.com/android The thing is, if you are depending on your mobile's data connection it will be a tough task for you because you have to download a PC application for this. Meanwhile, I will try to figure out your problem soon. –  The Dark Knight Feb 7 '13 at 20:37
    
Also, this ClockWorkMod Tether looks promising. He is a well known developer play.google.com/store/apps/… For this, you don't have to have an internet connection in your PC. so give try on this first. Read its description for more information on how to do. –  The Dark Knight Feb 7 '13 at 20:39
    
Thanks for the help but it all seems quite complicated when it was 'plug and play' originally and just stopped working for no reason. Mind you, my PC started shutting down every night and when I investigated, the Windows update setting had been changed to automatic, instead of letting me decide to install. How??? I hadn't touched it! Chances are an update has screwed something up. –  user28076 Feb 7 '13 at 20:47
    
And I do have an internet connection on my PC - most of the time. NZ broadband is a bit unreliable and so when it goes offline, I like to be able to use my mobile to connect so I don't have to stop working. –  user28076 Feb 7 '13 at 20:48

protected by Community Nov 8 '13 at 12:13

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.