Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have one Samsung tablet and one Samsung mobile phone. When I insert my Airtel SIM in tablet then it automatically sends one SMS to an unknown number, and when I insert the same SIM card into my mobile then it again sends one SMS to an unknown number. So every time an amount is deducted from my balance.

I don't know what is the problem and how to get out from this problem?

Is it a problem with the SIM card or with the mobile/tablet?

share|improve this question
3  
Possible duplicate of: android.stackexchange.com/questions/32087/… –  geffchang Feb 14 '13 at 6:24
1  
+1 for that hint with the duplicate, GreenGuy! @VinitVikash: Please check its first answer, it pretty much sounds like a perfect match to your problem. –  Izzy Feb 14 '13 at 7:45
    
Here in my case "Sim change Alert" box is unchecked then why it send SMS??? All the setting are factory set. –  Vinit Vikash Feb 14 '13 at 9:44
2  
NO this question is not duplicate of other question. Here in my case "SIM change alert" box is unchecked but it till send SMS when I insert new SIM into the mobile. –  Vinit Vikash Feb 14 '13 at 9:49
    
Have you followed the debugging steps used in that post? Install RL Permissions and see what apps ave permission to send SMS, and then which apps can start at boot. The culprit is likely one of the applications that has both permissions. –  Michael Kohne Apr 12 '13 at 13:07
add comment

3 Answers 3

up vote 0 down vote accepted

Hey I got solution after giving lot of time on this problem. This is the defect of Samsung Software. Actually every software version is linked with some number. But it not send any sms to that number. Because of licence, security reason they need to linked every version to particular number. If some problem occur in mobile phone then only it communicate with this number. But in some particular software there is some defect that's why it send sms when new SIM inserted into mobile.

The solution is go to your nearest Samsung Service Center and update your software.

share|improve this answer
add comment

I had a similar problem. I had enabled mobile tracker & that why the SMS's were going. Disable the tracker & the sms'es will not be send out on sim change.

share|improve this answer
add comment

Before changing the SIM, set your phone to flight mode. Then switch it off, and change the SIM. Switch on after 5 minutes, and disable the flight mode. It will help you save your balance deduction.

share|improve this answer
add comment

protected by Community Jan 3 at 14:59

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.