Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a Samsung Galaxy S (GT-i9000), running Android 2.3.4. I cannot send a message that includes more than one page of SMS. The message sending fail if it includes more than 160 characters. I can send only one page of SMS. Guess it's a kind of an edited version. That version came with the brand new phone. The phone does not work with ''ginger bread'' or ''ice cream sandwich''. What should be done to make it clear?

share|improve this question
    
Just to clarify: The device is running Android 2.3.4, but does not work with Gingerbread -- so it does not work at all currently? Hint: Gingerbread = Android 2.3.x :) –  Izzy Feb 14 '13 at 18:23
    
SMS messages over 160 characters are often sent as MMS messages - confirm with your provider that MMS service is active on your line and that the APN settings for MMS are correct on your phone. –  Mr. Buster Feb 14 '13 at 21:13
add comment

1 Answer 1

Go to Settings > wireless and network > mobile networks.
In the network mode, select GSM only.
I was having the same issue, and this step solved the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.