Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a Motorola Electrify M, recently factory-OTA-updated to Android 4.1.2. With the update came Google Now and the Google Voice Dialer.

Google's Voice Dialer sucks! It always get the name wrong, and then immediately places a call to the wrong person! It doesn't even ask for confirmation of the name, and to top it off the voice it uses is so irritating and LOUD it makes me want to jump out the window while driving down the freeway!

The Voice Commands app that originally came with the phone worked reasonably well, and I'd like to get it back (or even a third party app, like Dragon Assist, would be better than the current POS that's taken over the voice capabilities of my phone).

How can the Google Voice Dialer be disabled or uninstalled?

share|improve this question
    
It looks like this issue has been logged on the Android bug tracking site: code.google.com/p/android/issues/detail?id=35199 –  Jim Fell Feb 14 '13 at 18:06
    
For a quick solution: Settings->Apps->Manage Apps, scroll to the app, tap it, tap the "Disable" button (if not grayed out). –  Izzy Feb 14 '13 at 18:29
    
@Izzy Unfortunately, neither Google Voice Dialer or Google Now (or variants on those names) are in the list of installed Apps. –  Jim Fell Feb 14 '13 at 18:45
    
I figured out how to disable Google Now, but Google Voice Dialer remains. It seems that they are not directly related, but two separate products. –  Jim Fell Feb 14 '13 at 19:19
    
Would you mind to let us know what you've figured out? Feel free to answer your own question if you can, that's perfectly fine. And sorry for that "disable" mistake above: Though I have some 4.x devices, I never thought about disabling what I've not installed :) –  Izzy Feb 14 '13 at 21:38

4 Answers 4

up vote 1 down vote accepted

Okay, I figured out how to set the good ol' Voice Commands app as the default voice commands interface. It has to be done while not connected to a hands free device via Bluetooth.

  1. Tap into the Phone app
  2. Tap the Phone app's microphone icon

In my case a prompt appeared asking me to select the default app to handle voice commands. Thereafter, it's used the correct Voice Commands app when connected via Bluetooth.


For those who wanted to know how to disable Google Now, here's how it's done:

  1. Swipe up from the Home icon to activate Google Now
  2. Scroll all the way to the bottom
  3. Tap the Overflow menu (three vertical dot icon)
  4. Tap Settings
  5. Tap Google Now
  6. Tap the OFF/ON switch in the upper-right to disable Google Now
share|improve this answer

I agree the Google Voice Dialer is horrible! I was able to restore the Android Voice Commands on my Droid Razr Maxx by doing the following:

  1. Go to Manage Apps, then swipe over to All apps.
  2. Look for Google Search then Disable it.

This is probably all you need to do, but I went about it probably the wrong way by also doing the following.

  1. In Manage Apps, click on your menu button and Reset App Preferences.
  2. Ihe Google Search, click the "Clear Data" button.

The next time I pressed my BlueTooth Call button, it asked if I want to complete it with My MotoSpeak or Voice Commands, either Always or Just Once. I selected Always it works again!

share|improve this answer

I have a Motorola Droid, was getting great voice dialing using my BT Voyager Pro via the "Voice Commands" app (same as Mic Icon) but after the Android 4.2 update, Google Voice was activated and was a disaster.

To fix this I went to Settings > Apps> Google search and deactivated it. This fixed my voice dialing problem (went back to "Voice Commands") but the search (magnifying glass icon) on my phone went dead. I then went to the Android store and downloaded/installed the new "Google Search" app. When I used voice dialing for the first time, it gave me the option of either using Voice Commands (mic icon) or Google Voice (I think a read icon). I chose the first one and now it works as before. The search button is also working as intended.

The above may sound trivial, but when one is driving and wants to make a call, having to hold your phone to type the number after 5 failed attempts to voice dial is the last thing you want to do.

share|improve this answer

The method above works, or did for me -- disable Google, but I found out later that while it still lets Google work as a search engine (or does for me), it killed Maps which means you can't use Navigation. If you want to re-enable Google, follow the same steps: Setting, Apps, All, then scroll to the bottom and you'll find the disabled Google. Re-enable and Maps works but you're back to the horrible Google Voice Dialer. It's either/or (good voice dial or maps/nav) until Google fixes the operating system.

share|improve this answer

protected by Community Mar 28 '13 at 9:45

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.