Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a Galaxy S3 and a data plan.

I prefer using wifi whenever possible.

I tried to connect to a few networks, both private and public but I always get the same result: phone will say "connecting..." or "obtaining IP address..." without actually connecting.

Restarting the phone won't work. Simply restarting wifi won't work.

A filtered log of "WiFi" is available here. I used LogCat for it. I also tried to disalbe DroidWall but didn't help. I don't remember what I have done before this occurred. Last option would be formatting phone and restoring TitaniumBackup

Any idea on how to connect again to home and other networks?

[Edit] It looks like the device connects only to one or few networks.

I have a Vodafone Station 2 router at home. I usually keep the built-in wifi disabled. When I enabled it, I was able to connect the phone to it.

I thought this could have been related to the installation of the Vodafone Station 2 app on the very beginning. My suspects become clear when the device is able to connect only to a Vodafone-xxx network but I have wiped the device. I have tried to connect the device during Android configuration without success.

[Edit] This suggests to me that it's a hardware problem. After upgrading to stock 4.1.2 I don't get the same error as before (good news) but instead it repeatedly refuses the WPA2 password for the home network. To be precise: I did the Vodafone-test only after upgrading ROM.

The Vodafone Station 2 router features wifi 802.11 a/b/g/n where my plain old home router only supports b/g. I have tried to configure Station for b only just to see if the device stopped connecting. I have no means of stripping Vodafone prefix from SSID in VS2 router

[Edit] Anyway I have another log. I don't want to separate myself from my device for too long. I'll try to install the stockest ROM for GS3 and to update via OTA.

Here are the logs: http://pastebin.ca/2317414 http://pastebin.ca/2317416

Notable line

02-26 20:30:03.880 E/WifiHW  (17931): Unable to open connection to supplicant on "/data/misc/wifi/sockets/p2p0": Connection refused

But I'm not using Wifi Direct!!!!!!!!!!

[Edit] notable line after reverting to oldest stock ROM

I/wpa_supplicant( 6982): CTRL-EVENT-ASSOC-REJECT bssid=2C.DA.82 status_code=16

[Edit] striked the Vodafone part. Simply the phone connects to the router if you are a few centimetres from it. If you get past about a metre's treshold the phone won't connect. This seems to be a widespread problem affecting Samsung devices, especially Nexus for what I have seen so far.

share|improve this question
    
From your log: WiFi Eanbled with p2p -> disable ==> Could it be you're trying something with WiFi direct (p2p) instead of using normal WiFi? –  Izzy Feb 15 '13 at 10:43
    
No I'm not. I also deleted and re-set-up a connection by clicking on it and inserting WPA password. Maybe I've got an application messing up with Wifi Direct? –  djechelon Feb 15 '13 at 10:57
    
I'm not sure (I'm no dev, so with some things I can only guess). But from the logs it looks to me as if it's in p2p mode (wifi direct), and so discards all networks found as "unknown" (i.e. protocol does not match, I guess). You might just check in settings->wireless if wifi direct is checked (if so, uncheck it). –  Izzy Feb 15 '13 at 11:08
    
I have no checkmark but I have a button next to "Scan". In the Wifi Direct menu I can scan for P2P devices but I see no option to disable it –  djechelon Feb 15 '13 at 11:10
    
Anyway this forum (android.net/forum/samsung-galaxy-s2/…) suggests wipe –  djechelon Feb 15 '13 at 11:15
show 5 more comments

1 Answer

But I'm not using P2P! => P2P in this context is not meant in the sense of "peer-to-peer file sharing". It's a type of socket communication -- think of it as "point-to-point": one point is your device, the other might be the/your router where it should connect to.

The error message you quoted can be found in the Android code of wifi/wifi.c, in a part suggesting it's a WPA issue (I'm not an Android programmer, so I cannot tell for sure). Your problem was e.g. also reported in a German post at AndroidPIT (Google-translated variant). The reporter there found an easy solution: Resetting the router solved it for him.

In case this doesn't work for you, more information might be found using this Google search.

share|improve this answer
    
Thanks for the information. I should downvote the P2P part because I and the other commenter meant "wifi Direct" which is a peer to peer level 3 protocol. Skype is a different matter and is an application. Most important, I don't have Skype when wiping the device. The real problem is that I can't obviously reset public hotspots. Anyway I'm going to dig into the article. –  djechelon Feb 28 '13 at 10:22
    
The first paragraph was intended to differenciate between "peer-to-peer file sharing" and general "peer-to-peer"/"point-to-point" socket communication, just for clarification (I just updated it to make it more clear). I had preferred putting the above into a comment, but it wouldn't have fit (too long). And sure, you cannot reset public hotspots -- but you also didn't explicitly mention those being involved ;) –  Izzy Feb 28 '13 at 10:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.