Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

When I try to access secure web sites via https (ssl), I get an error.

Chrome error message:

Error 107 (net::ERR_SSL_PROTOCOL_ERROR) SSL_Protocol Error

Firefox error message:

ssl_error_rx_record_too_long

The website load correctly on Wifi, but this error shows up when trying to load pages over a cellular data connection.

I am running Cyanogenmod 10 (Android 4.1.2) from Bell (Canada), though the problem also happens on stock Android (according to other forums on other carriers).

I tried following one person's suggestion to modify the TLD settings in the about:config page for Firefox, but that did not fix the problem.

share|improve this question

closed as too localized by roxan, t0mm13b, ce4, Ryan Conrad, Bryan Denny Feb 20 '13 at 20:02

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Have you considered posting to CyanogenMod forums about this? –  t0mm13b Feb 15 '13 at 23:28
    
Hmm, maybe your carrier is messing around with SSL connections. –  Flow Feb 18 '13 at 18:49
3  
Turns out I had to remove the proxy settings from the data network. –  AnthonyM Feb 21 '13 at 22:07

Browse other questions tagged or ask your own question.