Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have Galaxy Tab 7.7 tablet running Android 3.2. Recently, I'm having connection problems to my home Wifi router. The device keeps scanning for Wifi access points for long periods. My home Wifi router is shown with a "Not in range" message next to it in the Wifi settings screen. However, sometimes after long period of time, the device randomly connects to the Wifi router.

It is worth mentioning that during the scanning mode the device does not detect any Wifi access point even thought where I live there are many Wifi access points (over 8 access points).

What is the solution to my problem?

share|improve this question
    
I had the very same case a while ago with my HTC Wildfire, after having flashed CM7 over the stock ROM. It solved when I also updated the radio firmware, and now still runs fine with CM9.1. If you made similar changes, this might be worth a try; otherwise I don't know anything apart from a Dalvik Wipe or factory reset. –  Izzy Feb 20 '13 at 19:59
    
@Izzy Thanks God. No need for factory hard reset :) –  Mohammad Al-Turkistany Feb 25 '13 at 17:33
add comment

2 Answers 2

I was having the same problem, but I can connect easily at home (automatic) but my problem was at work. I just changed some of the settings. Turned connections optimizer (yesterday in order to connect I had to turn it off) and reset wi-fi timer for 7a-5p. We'll see how that works once I get home. The settings have been on set for approx. 10 min and I haven't lost the signal. Decreased but not lost.

share|improve this answer
add comment

The solution turns out very trivial and surprising. It shows and proves practically that the behavior of complex software systems is unpredictable.

The solution: Go to Mobile network settings and disable Use packet data. Next, enable Wifi and then go back and enable Use packet data.

Magically, all my problems disappeared after I applied described steps.

share|improve this answer
    
Woah! who would have thought of that... Glad it solved that easy, and (even better) did not need a factory reset! –  Izzy Feb 25 '13 at 19:39
    
I guess there is some conflict between the code that handles Wifi functions and the code handling 3G networking functions. –  Mohammad Al-Turkistany Feb 25 '13 at 19:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.