Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I do not see them in the /clockworkmod folder when I connect my device to my PC. I tried using adb pull but adb does not show any devices when the device is in recovery mode (only if it's booted).

Version is 4.2.1; ROM Cyanogen.

EDIT (for add. information): Device is MAKO, and the OS is win7. The drivers for the device have already been added/installed from the android-sdk extras folder.

EDIT (more information): The folders I see when I connect the device to win7 are different than those I see when I browse on the device itself.

EDIT: this issue pertains to the way 4.2.1/4.2.2 creates folders (something about multi-user) - http://stackoverflow.com/questions/14005176/adb-not-recognising-nexus-4

share|improve this question
What device is this? –  Compro01 Feb 20 '13 at 19:14
What OS is your PC running? You might either need to install suitable drivers (Windows) or add a line to your UDEV config (Linux) for your device to show up. –  Izzy Feb 20 '13 at 19:26
Updated original w/ answers to these. Yes, the device shows up properly in Win7. –  jhstuckey Feb 20 '13 at 20:16
Have you tried using file manager app, and verify if the folder really exist in the phone? It's silly, but better make sure. –  Hossain Khan Feb 20 '13 at 20:43
To add some information to this question: the directories I see when I plug the phone in and those I see in the phone are different. –  jhstuckey Feb 22 '13 at 2:43

2 Answers 2

The ROM Manager app has an option in the Manage and Restore Backups to Download Backups. You might want to try using it to create backups and download those backups to your computer.

enter image description here

Choose Download Backups and you will see:

enter image description here

Provided your phone and your computer are logged into the same network you can point your browser to the address shown on the screen and choose which of the backups you would like to transfer to your computer.

It will take a while depending on the size of the backup.

This may be a feature of the Pro Version but the Pro version is worth every penny.

Good Luck.

share|improve this answer
thanks for that! I've found that using recovery to handle backups to be easier, but this seems to change that. –  jhstuckey Feb 22 '13 at 23:42

I'm not 100% sure if the following will solve your Problems, but I had similar problems with my Nexus 4 (mako)

First up: The Backups will probably be stored in "/data/media/clockworkmod" you probably won't find them somewhere else.

Second Problem: I had the same Problem, with not getting ADB-Access in Recovery Mode what I did was (Windows) going to Device Manager and selected "ADB Composite Interface" for the unknown device. Automatic driver searching did not succeed.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.