Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I use a Google Voice phone number to receive texts, and I have the Google Voice app installed on my device (Atrix, OS:2.3.3).

For some reason lately when someone texts my Google Voice account it's not getting sent to my phone. For example:

  • I got a text at 9:00 this morning (time is now 1PM)
  • If I visit voice.google.com, I see I have a text in my inbox.
  • If I open the Google Voice app on my phone, it does the 'synchronizing' spinning wheel animation for a few seconds and then I get the 'new text' notification, which is now 4 hours late.

In my Google Voice app's options, I have Background data: Enabled. Why isn't it pushing my texts when they are received? I get Gmail messages delivered to my phone near instantly, but I'm not getting the same behavior with GV.

Any ideas?

share|improve this question
    
Have you also enabled auto-sync. It might also be a problem with the network specially if 3G coverage in your area is spotty –  forums Feb 22 '13 at 2:56
    
I don't recall seeing such an option such as 'auto-sync', can you say where you saw it? The 3G in my area is pretty solid, I've usually got 4 or 5 bars. –  Tim Feb 22 '13 at 3:36
    
It's in the Settings -> Accounts & sync -> Activate auto-sync, just right under Background Data. But if you're on ICS or newer, tap your account and see if data sync for each items are checked –  forums Feb 22 '13 at 4:17
    
Hmm, you must have a different version than me, because I don't see any such menus. Under settings I just have Accounts, and Battery & Data Manager. Under Data Delivery, I have Background data checkbox, but there's nothing under it called auto-sync. Maybe it's the motorola skin, not sure. Based on the number of other complaints I see about this issue I'll have to guess it's some flaw with the app and not with the android environment, but hard to be sure. –  Tim Feb 22 '13 at 4:55
    
my Settings is AOSP-based so your settings must be running on Moto's skin. Also is this issue just recent? –  forums Feb 22 '13 at 5:06

1 Answer 1

I'm not really sure why it happens, but I've experienced the same issue in the past with the very same phone. It usually happened when I was travelling, such that once I arrived at a new destination, I'd suddenly get text messages delivered. The issue did seem to go away when I installed a custom rom (the latest Cyanogenmod at the time). I've since gotten another phone and have never experienced the issue. If you're feeling brave, I recommend flashing a newer rom.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.