Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have version 2.3.3 of the stock android browser on my phone. I know there are newer versions out that support features that I want which are not available in 2.3.3. However, I do not see any upgrades available, and in fact the stock browser does not even show up in the Google Play store.

I figure I probably need to manually install from somewhere, but where do I find the necessary files and how do I perform the upgrade? Note: I am not interested in upgrading to a newer version of Android.

share|improve this question
    
Firefox mobile supports Android 2.2 and above is you're stuck with an older version of Android and needs features that aren't available in older browsers. –  Lie Ryan Aug 27 at 13:04

1 Answer 1

up vote 1 down vote accepted

Check this XDA post. It has an APK for a 4.2 AOSP browser.

NOTE: Install at your own risk.

share|improve this answer

protected by Community Oct 25 at 11:25

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.