Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I am trying to use my VPS running Cent OS as a proxy via SSH from my Galaxy S3 running Cyanogen Mod 9.

I can connect to my VPS using ConnectBot. In this program I sett the Port Forward to:
Type: Local
Source port: 8080
Destination: localhost:80

I am using Firefox browser with the Proxy Mobile 0.0.10 add-on. In those options I change all the hosts to localhost and proxy ports to 8080.

When I try any web address they all redirect to the default Apache 2 screen on my VPS instead of passing the traffic through from the web.

What do I need to change? Is there something in my SSH settings I need to fix? Is it something on my phone? I know the proxy works as I can get it running via Firefox on my desktop.

Many thanks.

share|improve this question
    
Do you have the proxy running on port 8080 or 80? Try changing the Port Forwarding to use the destination localhost:8080. –  onik Mar 5 '13 at 11:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.