Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I've been spending a lot of sleepless nights trying to fix this. I know there are a lot of threads like this on the internet, but I want to go a bit deeper.

I have an HTC Wildfire S with only 512 MB internal flash memory. This internal memory has a partition layout allocation around 130 MB for the /data partition and around 290 MB for the /system partition. Both of them are full. (In addition I got a 16 GB SD-card.)

Installing apps, upgrading apps, running most of the apps - impossible.

Now, I knew it's possible to move apps to SD-card, the so called apps2sd procedure which offers very limited functionality to move some of the application data to the SD-card. Anyways after moving every possible data to SD the internal memory was still full and the phone unusable.

I was reading about more sustainable methods like data2sd. I gave it a try. I used the instructions from htcdev.com to unlock the bootloader, I installed the latest ClockWorkMod Recovery and rooted the device permanently.

Finally, I used the rooted device to install Android 4.1.2 AOKP Jelly Bean Custom ROM and Data2SD like discribed in the linked articles. But I was stuck the device was not booting until I removed Data2SD. The AOKP-ROM was working pretty well and stable, but installing Data2SD simply did not work in combination with Jelly Bean (SD-card formatting: 11 GB FAT23, 4GB ext4 and 256 MB Swap).

Now, I tried to go for the link2sd approach. I reformatted my SD-card (14 GB FAT32 and 2GB ext4) and installed Link2SD on my phone as described here. I was able to move additional data and apps to my SD-card and could link some apps to the card.

And now after some days playing around with all that usefull tipps from the internet, for example this thread: What can I do to manage my phone's internal storage? - I am at the point where I started. This is my result: Internal memory is still full and the phone is still unusable. (I would love to post a screenshot, but taking screenshots simply does not work currently.)

Link2SD and still no space on internal memory!

How to finally fix my internal memory on the Wildfire S? Why is Data2SD not working with the Jelly Bean ROM and why is Link2SD so ineffective? Is there anything I'm doing wrong?

The main problem seems to be the Dalvik Cache on the /data partition (around 100 MB). Is there any way to completly use the SD card to somehow get partitions mounted at /data and /system?

share|improve this question
add comment

2 Answers

You've said that you partitioned before installing link2sd but not before installing data2sd. data2sd also requires extra partition just like link2sd.

The reason link2sd being not effective is because it moves all but data to sd-card. If any of your app uses huge data it will fill your internal space quickly.

Try going to Settings -> Apps -> Sort by data size and see which apps are on top and try clearing their data. This will free some space for some time but also clear that particular app's data.

As you've pointed out installing Dalvik cache to SD would be best. In my custom ROM I've to open terminal and type a2sd install and supply option y,n,y. Most probably this will work with your ROM as well.

share|improve this answer
    
I formatted the SD-card like described in the linked article: 11 GB FAT23, 4GB ext4 and 256 MB Swap. I already tried all simple approaches, clearing data, moving apps and so on. What is a2sd? I might give it a try. –  vertoe Mar 10 '13 at 19:55
add comment

I'd check what's taking up so much of the internal memory. I use SD Maid app, and use these functions: corpsefinder, systemcleaner, appcleaner, duplicates, biggest files.

When I couldn't install Google Maps after reflashing my CM10.1 with the latest nightly, I used the biggest files and delete some files I'd downloaded before (other nightlies that I've saved). I also deleted some files that were no longer being used. When I was done, I was able to install Google Maps.

share|improve this answer
    
I did. The largest bunch is the dalvik cache as stated in last paragraph. –  vertoe Mar 10 '13 at 19:50
add comment

protected by Community May 23 '13 at 13:59

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.