Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have an LG L5 (E610), running Android 4.0.3 (Ice Cream Sandwich MR1).

Recently, I moved all my contacts that were stored as Phone or SIM contacts to Google contacts in order to get them synced.

Now, I have only Google contacts.

But, when I create a new contact, the default store seems to be the Phone store, and I find no option where I can set Google as the default store.

Googling around a bit brought up one solution that sounded reasonable: display only the Google contacts, in the address book, then Google will be the default for a new contact. But, even this doesn't work; if I only display Google contacts, my phone still selects the Phone storage as default and I cannot see my newly created contact.

Any suggestions as to how I can set the default contact store? Or is this impossible?

share|improve this question
add comment

1 Answer 1

This worked for me. Try to go to Settings>Apps>All Apps>Contacts (not contact storage) and clear data. Also try to combine all the suggestions:

  1. cleared data in contacts app as written above
  2. selected the display only contacts from whatever you want
  3. made a dummy contact, selecting the desired store location
  4. reboot

I basically tried all the solutions, so it's a little hard to give the exact way to go about this. Hope this helps.

share|improve this answer
    
doesn't even need a reboot. Just tried out on my restored phone. Simply cleared contact data. Changed the settings to display only phones from... Tried adding phone number and the default location is as selected. Needed to do only 1,2 from the list –  Laura LG Apr 30 at 20:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.