Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I was a regular Galaxy SII user, recently moved to Galaxy Note-2 - so far so good, but since today, I am finding my Play Store application, is not working on Note-2 [it was, earlier], even from the PC, when I am trying to download an app via Google Play application, it says 'Installed', but actually nothing happens.

I click Play Store, the Home-screen comes back, Play Store is not activated.

Other than that, all are fine, Facebook, LinkedIn, SMS, Phone are healthy!!!

Can someone guide me please?

BTW the firmware as per KIES is "PDA:MB3 / PHONE:LL1 / CSC:MC1 (STS) and android is 4.1.2

share|improve this question
    
Can you link a screenshot of what it looks like when you try to install something from your Note 2? –  Cornholio Mar 18 '13 at 11:06

1 Answer 1

I had same problem. I tried this, and it worked: Settings > Application manager > All > Options > Reset the application preferences.

share|improve this answer

protected by Community Jul 15 '13 at 12:47

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.