Sign up ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have Samsung Galaxy Ace, rooted.

Today, I tried to install an application. It didn't install, but my phone memory reduced by around 10mb. Again, I tried to install another app, and the memory reduced by 12mb.

The apps are not installed. Their icons are not showing in the phone, but they are taking away space. Please help.

share|improve this question

4 Answers 4

If an installation fails, the downloaded .apk might still be left in /data/local (where the Playstore app downloads it to). In that case, a simple boot should clear it up.

As your device is rooted, you also could use a file manager to check that location, and manually delete the corresponding file.

One more hint: To avoid the "insufficient memory" / "insufficient storage" error (see: , hover you mouse over the tag and select the "info" link for more details), which also might be responsible for failed installations, you will need at least 25MB free space on "internal storage" / "phone storage" (that is, this amount should be available when the installation has finished).

share|improve this answer

Try to clear your cache using an application like History Eraser and to reboot all running applications using an application like Fast Reboot. This usually solves the problem. Hope this helps!

share|improve this answer

Remove the partially installed application by using a File Explorer software

go to 0/Android/obb/ look for the file partially installed

This was found out by self diagnosis.

share|improve this answer
OP states that "phone memory" was reduced. Your answer refers to *shared storage", i.e. sd card. – Izzy Jul 15 at 15:46

connect the device to computer with usb cable. goto android - obb. there u will find the file. delete it. memory will be recovered.

share|improve this answer
obb is only for games. Simple apps generally dont store data in obb folders. But maybe I am wrong. Can you please elaborate more with what might be happening here perhaps? – Jaskaranbir Singh Jun 28 at 9:24
@JaskaranbirSingh sorry to disappoint you. I'm just backed up my old tabbi yesterday (to replace it), and found several .obb files stored on it. I've never played games on it, and those files definitely have been from productivity apps. For details on OBB files, see e.g. APK Expansion Files and (German) APK Expansion Files (*.obb). – Izzy Jul 15 at 15:43
user114380: OBB files are usually not installed in "device storage" but on sd card. Quoting from the first link: When Google Play downloads your expansion files to a device, it saves them to the system's shared storage location. OP states that "phone memory" was reduced – so OBB files are unlikely to be the cause. Apart from that, this was already said by this answer. – Izzy Jul 15 at 15:45

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.