Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I am having a galaxy S3, I can't connect it to my laptop.When I connect it with USB it's not getting mounted and so unable to transfer any files.

In my laptop Samsung kies is not installed, hope it may be the problem but in my laptop kies is not getting installed its showing "no internet connected!!" even if am connected to WiFi. Am totally stuck and frustrated, please can anyone help.Its so painful to carry such a phone without file transfer :-(.

share|improve this question
1  
What OS are you running on your laptop? Which Android version is it on your S3? Have you checked the USB connection mode it uses (UMS, PTP, MTP)? I don't think Kies will help (except for slowing down your Laptop, there's not much it can do good as far as I've read). –  Izzy Mar 19 '13 at 7:38
    
laptop-Windows xp,Android Galaxy s3-4.1.1(jelly bean),Can you please help me, how to set this USB(UMS, PTP, MTP) connection mode?? –  Sree Dev Mar 19 '13 at 7:59
    
I have neither Windows nor an S3. But seeing it uses 4.1+ it most likely will support MTP (and AFAIK Windows-Explorer should be able to handle that). When you connected the USB cable, open the notification area. It should have an entry with the USB icon. Tapping that should allow you to chose the connection mode. I guess your default setting says "charge-only", which is why it doesn't appear to mount on your laptop. –  Izzy Mar 19 '13 at 8:11
    
And also i cant find USB utilities in my Android Phone.Its running in Android 4.1.1 jellybean how can i locate usb utils\???? –  Sree Dev Mar 19 '13 at 8:12
    
What should "USB Utils" be? There might be something like "USB Settings". Checking with my LG-P880, there's one fitting place: Settings->Connections->USB-Connection. Here I can chose the connection mode, and define it to always ask me what to do when a connection is established. Might be at the same/a similar place on your SGS3. –  Izzy Mar 19 '13 at 8:16
show 2 more comments

1 Answer

Select the 'Mass Storage Only' option in the USB settings and then connect the cable.

If this doesn't work, you can connect your laptop and your phone to the same wireless network and use AirDroid to transfer files wirelessly from your laptop to your phone and vice versa using a browser on your laptop. Both devices just have to be connected to the same wireless network (with or without internet access).

Hope this helps!

share|improve this answer
    
Is it fast enough to transfer file fast???i had heard about this.....but still these kies are not getting istalled to lap??? –  Sree Dev Mar 19 '13 at 8:30
1  
Depends on what you think is fast enough! I got similar speeds while transferring files through a USB cable and through AirDroid. You don't need kies for using AirDroid. Give a shot. Something is better than nothing! –  Ambar Mar 19 '13 at 8:42
    
yup thats correct will surely give a try and will let you about this...soon –  Sree Dev Mar 19 '13 at 8:44
    
@Ambar May I know where I can access the 'Mass Storage Only' option in the USB settings you mentioned? Is it available on Galaxy S4? Thank you! –  Han May 25 '13 at 23:31
    
@Han I am not too familiar with the Galaxy S4 but it seems like people cannot enable the Mass Storage Only option in this particular phone. Hope you find a solution soon! Cheers –  Ambar Jun 4 '13 at 12:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.