Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a HTC Wildfire with android 2.2 (I can't remember if this problem started right before or right after upgrading to 2.2, but the upgrade was done recently and so was the first time I got this problem). Sometimes (and it seems completely random) the screen lock function never works. When pressing the power button and pulling down the clock it tells me the screen is locked, but there is no lock there! When I pull it down I get to my home screen instead of the screen where I need to enter my lock pattern.

share|improve this question
Is this with the Sense UI? My non-HTC phone doesn't have a pull-down clock thing ... – Matthew Read Dec 29 '10 at 19:56
Perhaps, I don't know how it works with non-HTC android phones. – James Dec 29 '10 at 21:46

I think you'll find that is normal. I wondered about it at first too.. If you lock your phone by pressing the power button, your phone is LOCKED, but not SECURE. Because you have only just been using your phone, if you unlock it immediately by re-pressing the power button and pulling down the clock, you won't have to enter your pincode or pattern, because it's highly unlikely to have been stolen in the past 30 seconds. However if you lock your phone via the power button (or if it times out by itself) and then you leave it for a few minutes then the next time you drag down the clock to unlock it, you'll also have to enter your pincode or pattern, to verify that it's you.

If you want your phone to ask for your pincode every time, straight away, go to:

"Settings" > "security" > "lock phone after" > and select, "immediately".

I have mine set to 3 minutes for convenience.

Hope this helps..

share|improve this answer
hi..this does not seem to be working..i did exactly hat you wrote even switched it to "immediately"..still it isnt...advice wud be welcomed :) – user4270 Apr 10 '11 at 19:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.