Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Galaxy S, and my locale is English (UK). Is it possible to type accented letters, such as é to a textfield using the keyboard? If yes, how?

edit: I know I can use swype but please don't recommend it because my native language is not supported by Swype and it's really not comfortable to use swype in my case

share|improve this question

I'm not sure if it is the same on all devices, but if you long press on the letter e then you should see a pop-up that allows you to selected accented variations of the letter e.

share|improve this answer
May I know what your model is? Mine is Galaxy S, apparently Samsung has a custom keyboard, and that doesn't work – Fitri Dec 30 '10 at 16:23
The long press works on the HTC keyboard (Desire HD), and on the version of the Swipe beta I have installed. – Matt H Dec 30 '10 at 19:35
@Friti Galaxy S comes with Swype keyboard, right? I have it installed on Motorola Milestone, and the long press works perfectly. Maybe it is the language? – Willian Mitsuda Dec 31 '10 at 4:58
This works on my Galaxy S using the custom Samsung keyboard. – Matthew Read Jan 9 '11 at 21:46
@Fitri Works for me too on a UK Galaxy S i9000, running official Samsung Froyo release, using the Samsung Keyboard as input method, and locale set to "English (United Kingdom)" and the Samsung Keyboard Input Language set to "English (UK)" and portrait keyboard type set to "Qwerty Keypad" – GAThrawn Jan 10 '11 at 22:23

As Luke Dunstan answers: but if I remember well, you do need to have Froyo (2.2) installed. I don't think I had the accented characters when I had Android 2.1 runnding on my Galaxy s.

share|improve this answer
meh (not downvoting, but...) your "answer" is a comment – Argalatyr Jan 13 '11 at 18:59
@Argalaty: Any answer is a comment that way: fitri has not stated what version of Android is running on the device. Indeed long pressing the key is the answer, unless, as it was on my Galaxy , you were running Android 2.1. In my case, upgrading to Android 2.2 gave me this functionality (to be honest, maybe it was there before, but now the dots are displayed on the on screen keys, so that makes it much more obvious). So if, as I think, upgrading to 2.2 solves the problem, than my answer may be the solution. – Edelcom Jan 14 '11 at 7:21
It worked when my phone had Android 1.6 too. I just tried it on the Android 1.6 emulator and it works fine. – Luke Dunstan Jan 14 '11 at 16:00
@Luke Dunstan: It's not the first time I 'discover' something 'new' in Froyo, which was there before. And it won't be the last time, either. To my defense: I only had my phone 3 weeks before upgrading to 2.2. – Edelcom Jan 14 '11 at 16:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.