Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I rooted my Samsung Galaxy Note 2. Now I cannot get the internet on it. My purpose was to avoid paying sprint the extra 30 bucks a month for tethering to my Ipad. Now I cant even get the internet on the phone except with wi-fi. I am considering a factory restore because if my frustration. How can I give get internet without restoring to factory settings?

share|improve this question
    
Perhaps you flashed a wrong modem/radio firmware and hence the cellular radio does not work on your network? Going back to factory-defaults/reset would do nothing in that case. –  chorgox Mar 28 '13 at 15:10
1  
The full internet would not fit on your phone :) Honestly: Did you only root the device, or did you flash anything else? What process/method did you use for rooting? Are you getting any error messages? Have you checked your APN settings? –  Izzy Mar 28 '13 at 15:18
1  
Can you add links to what ROM you might be running or are you still running stock with root? Did you flash anything from recovery? Maybe some links to guides you followed would help. –  Mr. Monkey Mar 28 '13 at 15:40

1 Answer 1

What might be causing this:

The issue is with the new ROM. What company it is of? For example, I tried Cyanogen 10.1 in HTC HD2, and it was running perfect. But had a little speed issue, as when I started GPRS connection by sim card, the phone started to hang out. But that's not the subject. The main issue here is the Internet connection.

Or the Data Connection (Access Point) error. You might be setting access point which are not correct. Try to get some help from the Network provider or read some blogs online, to check what settings would work for your phone. Android phones have same settings all around, so that means a setting for Sony Xperia would work in Samsung Galaxy too.

What you should do:

  1. I tried another ROM in my current phone, Qmobile noir A8. It was letting me use Internet before the ROM update, so I was worried what to do? As I was also able to use WiFi, but not the data connection. So I first tried to do a factory reset. But all in vain, as I was having the ROM that has been installed, and my Stock ROM was no more in memory. So I tried to get help from there site, INCPak, No help! Then I tried to check my phone's settings. In settings I saw that there is no Access Point set. So I entered the configurations of my SIM card's grps there, and restarted the Data Connections. Bravo! I was able to get the Internet now! :)

  2. Try to get some help from the people who created this ROM, if this is a ROM created by someone who said: "I will not be responsible if you brick your device." then you have no idea what mess you are in to now. Go find a new ROM for your phone as this aint gonna work. But if you got a ROM from someone like Cyanogen then you can get some help by contacting them. Or you try the first method I posted. I am sure, you will get set by that one. If not, then try to edit the settings. That's all what an Android phone can get issues with.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.