Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Models: Samsung Galaxy Note 10.1, GT-N8013 (WiFi) and SCH-I925 (4G LTE) Android version 4.1.2

I've been experiencing problems with the overly aggressive Samsung soft keyboard popping up whenever I touch the screen to select an input field, even though I am using a Bluetooth keyboard, and only intend to use a Bluetooth keyboard with this device.

Constantly having to dismiss the soft keyboard is a major hindrance to filling out complex forms. In an attempt to work around the problem, I tried installing the Null Keyboard app from Google Play.
This works for a while, however whenever the Bluetooth connection is lost and reestablished, the Samsung soft keyboard, even though not selected as the default, pops up the following message:

Change input Method. To use Bluetooth keyboard, change input method to Samsung QWERTY

The Samsung soft keyboard then resets itself as default input method.

I have tried other workarounds, such as using the Perfect Keyboard app and decreasing its size to the bare minimum, but unfortunately the Samsung keyboard still watches like a hawk and pops up its insipid dialog and resets itself as the default every time a Bluetooth keyboard connection is established...and then proceeds to pop itself up at the first opportunity. This is irresponsible behavior. The Samsung soft keyboard knows the Bluetooth keyboard is there, yet not only can't it just go away when the Bluetooth keyboard is active, it insists on resetting itself as the default input method regardless of which alternative keyboard you may have selected.

Yes, I know I could root it and disable the otherwise undisableable Samsung keyboard, but unfortunately I need to be able to deal with this solution on about two dozen units in field deployment, so I pretty much need to keep things safe and simple. I'm not trying to do anything crazy - just use a Bluetooth keyboard for one of the primary reasons for which they were created - to be able to type without taking up screen real estate with a soft keyboard.

Has anybody found a workaround for this yet?

share|improve this question
add comment

7 Answers

I had the same problem with my GN10.1 I use samsung keyboard dock and the popup keyboard just annoyed me.

Because, I'm Lithuanian, I need a special characters (ąčęėįšųūž) for typing.

There is a https://play.google.com/store/apps/details?id=com.apedroid.hwkeyboardhelper advanced null keyboard with multilanguage support (basic one works just with english).

Off course, it's very easy to find it for free by using google.

It closes the pop-up software keyboard and I can touch the screeen and enter text without any problem.

share|improve this answer
1  
How how how? I use the full version of that software keyboard so it does not types “(Demo Version)” in all the time, and it is flexible enough to configure the keys. Also the Samsung keyboard doesn't supports the ‘ű’ (Hungarian) letter that I use often. I couldn't configure it to close the pop-up and use the keyboard helper instead. How did you pulled that off? –  Adam L. S. Nov 7 '13 at 18:37
    
Sorry, I couldn't wait for your reply, and so with the “hint” of this article: blog.apedroid.com/2013/01/… I figured that I had to turn on the old-style detection. (Or was it to remove the auto learning data?) Ugly, but works. –  Adam L. S. Nov 8 '13 at 22:30
add comment

After endless frustration with this issue, I have finally solved it without rooting the device.

The solution for me has been External Keyboard Helper Pro, a $2.45 app on the play store (a demo version is also available).

It detects when a bluetooth keyboard connects, and brings up a pop-up menu allowing you to select "External Keyboard" with two quick taps on the screen, which is definitely tolerable. This completely disables the on-screen keyboard, so I can type in peace (like having the Null keyboard installed).

A few seconds after powering off the bluetooth keyboard, the same dialog pops up, allowing me to equally quickly select my favorite Swype. After months of not being able to use my Bluetooth keyboard because of Samsung's inexplicably annoying implementation, I'm in heaven.

Note that in order to get it to work, I had to go into the Advanced Settings of External Keyboard Helper and enable "Old style detection."

share|improve this answer
    
Unfortunately, this does not seem to work for me. The infernal Samsung keyboard keeps taking back over whenever it detects the Bluetooth connection. A couple of times the timing has been just right and the selection dialog has come up just in time, but usually the Samsung Keyboard of Doom switches itself to default before External Keyboard Helper can be of help. –  user31472 Apr 15 at 16:03
add comment

Same problem here. I wound up rooting it. That alone won't let you disable (uncheck) the Samsung keyboard in Settings. I had to actually rename /system/app/SamsungIME.apk and /system/app/SamsungIME.odex.

Then I was able to use Null Keyboard as the default.

Crazy. I had no other reason to root it and you really shouldn't have to do this.

To avoid this sort of vendor-induced nonsense, and to avoid even having to use the Null Keyboard or similar app, every Android device with Bluetooth should allow you to select Bluetooth Keyboard as the default input method, alongside other input methods.

share|improve this answer
add comment

Anysoft keyboard from Google Play Store allows you to hide the onscreen keyboard automatically.

share|improve this answer
    
Well, the problem with that is that even if it is not selected the evil Samsung Soft Keyboard still watches for a Bluetooth keyboard connection and reselects itself. No alternate keyboard selection stays for long. –  user31472 Apr 15 at 14:14
add comment

I have been trying to figure this out for my new Galaxy Note 8.0, and have a workaround that works 98% of the time, which is a huge improvement. I started using Bluetooth Keep Active fro mthe play store. It has been mostly successful in tricking my tablet into thinking it was using the bluetooth even when it is asleep and prevented the awful Samsung default on-screen keyboard from turning itself on as the default. I set the timer at a one minute setting. I have been trying it with Null Keyboard, Anysoft Keyboard, Perfect Keyboard, and even turning off all on-screen keyboards. I'm not sure which default is the best to use with Keep Active yet - still fooling with it.

share|improve this answer
add comment

I was able to disable on-screen keyboards in Android "settings" on my Samsung Tab3. Now I can use my Logitech K810 finally with no annoying on-screen keyboards constantly popping up and obscuring 50% of my viewable area on my already smallish tablet screen. I'm running Android 4.2.2. In settings choose "Language and Input" and click on "default" keyboard option. When the popup menu appears, slide the "use on-screen keyboard" slider to the "NO" position. It's not much hassle to go back to settings to slide it back to the "YES" position when my external keyboard is not available. I assume this is an easier fix than installing 3d party software like that "Null keyboard" app.

share|improve this answer
add comment

The best bet, if you are using the chrome browser is to use "tab" to select the field (if you want to select the url bar to search). Another way (if your keyboard has is) is to use the "magnifying glass" quick search button. I noticed that this selects the url and allows you to type a new entry and search.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.