Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

My SGS3 is recognised -- but it does not connect or transfer files, not even a backup!

I have tried everything from numerous cables to different PCs & even a Mac (because I'm a Mac user). I've used a PC to satisfy myself that it's not my Mac and nothing has worked.

Any suggestions? Should I contact samsung and say "Give me a new one"? But what good is that when all my files photos and music are on this that won't back up!!

share|improve this question
    
Have you checked what USB connection mode is set? Maybe it is set to "charge only"? Do you have an USB entry in your notification area when connected? –  Izzy Apr 4 '13 at 11:08

1 Answer 1

I've had this issue with my S3 sometimes. Alternatively, what you could try is download and install the drivers from here: link. Or you could also try changing the USB mode from MTP mode to camera mode (from the notifications). Don't forget to restart after installing!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.